Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

quickstart vm ignore /etc/hadoop configs

avatar
Explorer

I've moved from quickstart vm 5.3 to 5.8 and found that yarn config in /etc/hadoop ignored by system. I can change some settings via Cloudera Manager, but looks like in version 5.8 the settings is not stored in /etc/hadoop

 

I've got Java heap space error in my yarn jobs, the error very close to the issue solved before on 5.3

http://community.cloudera.com/t5/Hadoop-101-Training-Quickstart/Map-and-Reduce-Error-Java-heap-space...

 

but now I do not see any influence on system after changes in /etc/hadoop configs.

export HADOOP_OPTS="-Xmx5096m" also is not working for me.

1 ACCEPTED SOLUTION

avatar
Explorer
1 REPLY 1

avatar
Explorer

Solution found, the config chages was marked as "Stale Configuration"

https://www.cloudera.com/documentation/enterprise/5-6-x/topics/cm_mc_client_config.html