Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 02-15-2018 07:01 PM
Getting a weird issue : "ambari-server setup" fails instantly when running it for the first time. Getting this : "line 84: line: unbound variable"
context :
Trying to install a new HDP 2.6 cluster onto physical hardware (for a POC). Running CentOS 6.9 - fresh OS install. Following this doc : https://docs.hortonworks.com/HDPDocuments/Ambari-2.6.1.0/bk_ambari-installation/content/set_up_the_a...
Added the Ambari repo, installed the ambari package(ambari-server-2.6.1.0-143.x86_64) then proceeded to follow the rest of the documentation but can't find the issue here.
It's not the first time I spool up such cluster but it is the first time with this specific version - any ideas what could be the issue?
Line 84 is a simple version calculation : "numversion=$(( 10 * $majversion + $minversion))" not sure where this is coming from.
Created 02-15-2018 07:31 PM
Found the problem a couple of minutes after posting this.
After reviewing installation logs, the RPM package did not install successfully... but was reported as successful :
[...] Running Transaction Installing : ambari-server-2.6.1.0-143.x86_64 1/1 /var/tmp/rpm-tmp.SHIahM: line 27: //var/lib/ambari-server/install-helper.sh: Permission denied [...]
==> Turns out the /var mount point on this very specific machine (configuration management issue) was mounted noexec. Fixed the mount, reinstalled the RPM and I can proceed now.
Created 02-15-2018 07:31 PM
Found the problem a couple of minutes after posting this.
After reviewing installation logs, the RPM package did not install successfully... but was reported as successful :
[...] Running Transaction Installing : ambari-server-2.6.1.0-143.x86_64 1/1 /var/tmp/rpm-tmp.SHIahM: line 27: //var/lib/ambari-server/install-helper.sh: Permission denied [...]
==> Turns out the /var mount point on this very specific machine (configuration management issue) was mounted noexec. Fixed the mount, reinstalled the RPM and I can proceed now.
Created 07-31-2018 01:51 PM
Hello I have the same error but my /var is mounted noexec but ambari-server setup doesn't work! any help please