Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 06-06-2018 05:26 PM
I'm trying to install 3 node cluster on redhat 7.5. I'm able to install all basic services except hive.
1) getting mysql-community-server error
2) Installed maria db to resolve this and i'm unable to install mysql server.
here is the log:
Traceback (most recent call last):
File "/var/lib/ambari-agent/cache/common-services/HIVE/0.12.0.2.0/package/scripts/mysql_server.py", line 64, in <module>
MysqlServer().execute()
File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 329, in execute
method(env)
File "/var/lib/ambari-agent/cache/common-services/HIVE/0.12.0.2.0/package/scripts/mysql_server.py", line 33, in install
self.install_packages(env)
File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 708, in install_packages
retry_count=agent_stack_retry_count)
File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 166, in __init__
self.env.run()
File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 160, in run
self.run_action(resource, action)
File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 124, in run_action
provider_action()
File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py", line 54, in action_install
self.install_package(package_name, self.resource.use_repos, self.resource.skip_repos)
File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/yumrpm.py", line 53, in install_package
self.checked_call_with_retries(cmd, sudo=True, logoutput=self.get_logoutput())
File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py", line 86, in checked_call_with_retries
return self._call_with_retries(cmd, is_checked=True, **kwargs)
File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py", line 98, in _call_with_retries
code, out = func(cmd, **kwargs)
File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 72, in inner
result = function(command, **kwargs)
File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 102, in checked_call
tries=tries, try_sleep=try_sleep, timeout_kill_strategy=timeout_kill_strategy)
File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 150, in _call_wrapper
result = _call(command, **kwargs_copy)
File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 303, in _call
raise ExecutionFailed(err_msg, code, out, err)
resource_management.core.exceptions.ExecutionFailed: Execution of '/usr/bin/yum -d 0 -e 0 -y install mysql-community-server' returned 1. Error: Nothing to do
Loaded plugins: langpacks, product-id, subscription-manager
Created 06-11-2018 02:04 PM
installed mariadb and followed this doc for manually installing hive using existing database
Created 06-06-2018 07:44 PM
@raghavendra v Error is due yum command at os level is failing. Try to run the same command yourself on the host you plan to install hive.
yum -d 0 -e 0 -y install mysql-community-server
See exactly why the above is failing. If not able to find the mysql-community-server package you may need to add the repository for this to work:
wget https://dev.mysql.com/get/mysql57-community-release-el7-11.noarch.rpm rpm -ivh mysql57-community-release-el7-11.noarch.rpm
HTH
*** If you found this answer addressed your question, please take a moment to login and click the "accept" link on the answer.
Created 06-07-2018 12:51 PM
Please try the "localinstall" option with yum:
# yum localinstall https://dev.mysql.com/get/mysql57-community-release-el7-8.noarch.rpm # yum install mysql-community-server -y
.
Created 06-07-2018 12:53 PM
Followed by:
# systemctl start mysqld.service
- Obtain a randomly generated MySQL root password:
# grep 'A temporary password is generated for root@localhost' /var/log/mysqld.log |tail -1
.
- Reset the MySQL root password. Enter the following command. You are prompted for the password you obtained in the previous step. MySQL then asks you to change the password.
# /usr/bin/mysql_secure_installation
.
Created 06-11-2018 01:44 PM
Were you able to install mysql?
Created 06-07-2018 12:51 PM
Thanks for the reply. I tried the above cmd. but no use:
# yum -d 0 -e 0 -y install mysql-community-server
Error: Nothing to do
Loaded plugins: langpacks, product-id, subscription-manager
Created 06-07-2018 01:06 PM
Jay thanks for headsup on this tried the above cmd. still facing the conflict. I installed maria db as an option earlier
Loaded plugins: enabled_repos_upload, langpacks, package_upload, product-id, search-disabled-repos, subscription-manager
Examining mysql57-community-release-el7-8.noarch.rpm: mysql57-community-release-el7-8.noarch
Marking mysql57-community-release-el7-8.noarch.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package mysql57-community-release.noarch 0:el7-8 will be installed
--> Processing Conflict: mysql57-community-release-el7-8.noarch conflicts mysql-community-release
rhel-7-server-extras-rpms | 2.0 kB 00:00:00
rhel-7-server-fastrack-rpms | 1.7 kB 00:00:00
rhel-7-server-optional-rpms | 2.0 kB 00:00:00
rhel-7-server-rpms | 2.0 kB 00:00:00
rhel-7-server-satellite-tools-6.3-puppet4-rpms | 2.1 kB 00:00:00
rhel-7-server-satellite-tools-6.3-rpms | 2.1 kB 00:00:00
No package matched to upgrade: mysql57-community-release
--> Finished Dependency Resolution
Error: mysql57-community-release conflicts with mysql-community-release-el7-5.noarch
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
Uploading Enabled Repositories Report
Loaded plugins: langpacks, product-id, subscription-manager
tried --skip-broken option too
Created 06-11-2018 02:04 PM
installed mariadb and followed this doc for manually installing hive using existing database