Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 02-10-2016 08:35 AM - edited 09-16-2022 03:03 AM
ambari-server start Using python /usr/bin/python2 Starting ambari-server Ambari Server running with administrator privileges. Organizing resource files at /var/lib/ambari-server/resources...
WARNING: setpgid(2296, 0) failed - [Errno 13] Permission denied Server PID at: /var/run/ambari-server/ambari-server.pid Server out at: /var/log/ambari-server/ambari-server.out Server log at: /var/log/ambari-server/ambari-server.log Waiting for server start....................
Ambari Server 'start' completed successfully.
But server getting stopped automatically.
I can refer to https://community.hortonworks.com/questions/10044/ambari-server-start-warning-setpgid4340-0-failed-e... but didn't make any sense on how to apply the patch.
Any help would be great....! Any clear steps to resolve the issue and apply patch.
Thanks
Created 02-15-2016 03:10 AM
See this article https://community.hortonworks.com/articles/16944/warning-setpgid31734-0-failed-errno-13-permission.h...
I reproduced the issue and fix is in the link ..
Created 02-10-2016 09:29 AM
Hi Vinod,
You can use following steps to apply patch on your server.
1. Download patch to local or server.
2. You can use below command to apply it under ambari home dir.
$ patch -p0 -i /path/to/AMBARI-14466.patch
Created 02-15-2016 03:10 AM
See this article https://community.hortonworks.com/articles/16944/warning-setpgid31734-0-failed-errno-13-permission.h...
I reproduced the issue and fix is in the link ..
Created 02-15-2016 05:39 AM
@Neeraj Sabharwal Thanks Neeraj for helping this out. It worked for me too.
But ambari showing started but yet its getting stopped for me because of the following issue in log files.
DBAccessorImpl:102 - Error while creating database accessor org.postgresql.util.PSQLException: FATAL: no pg_hba.conf entry for host "127.0.0.1", user "ambari", database "ambari", SSL off
Could you help on this issue also please?
Created 02-15-2016 11:51 AM
@Vinod Nerella Its different issue. Its related to postgres. See this