Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 03-02-2016 12:44 AM
Hi,
It was running fine, but suddenly, I started getting below error, Does anyone know what can be the issue?
I restarted zookeepr from ambari as well.
[root@ttsv-lab-vmdb-01 ~]# /usr/hdp/current/kafka-broker/bin/kafka-console-consumer.sh --zookeepelocalhost:2081 --topic 56d4a92bb0073e537755b461 --from-beginning [2016-03-01 16:37:13,249] WARN Session 0x0 for server null, unexpected error, closing socket connection and attempting reconnect (org.apache.zookeeper.ClientCnxn) java.net.ConnectException: Connection refused at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method) at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:739) at org.apache.zookeeper.ClientCnxnSocketNIO.doTransport(ClientCnxnSocketNIO.java:361) at org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1125) [2016-03-01 16:37:13,354] WARN Session 0x0 for server null, unexpected error, closing socket connection and attempting reconnect (org.apache.zookeeper.ClientCnxn) java.net.ConnectException: Connection refused
Created 03-02-2016 12:46 AM
Try this
./kafka-console-producer.sh --broker-list borkerhost:6667 --topic test
./kafka-console-consumer.sh --zookeeper localhost:2181 --topic test --from-beginning
Created 03-02-2016 12:46 AM
Try this
./kafka-console-producer.sh --broker-list borkerhost:6667 --topic test
./kafka-console-consumer.sh --zookeeper localhost:2181 --topic test --from-beginning
Created 03-02-2016 12:48 AM
WARN Session0x0for server null, unexpected error, closing socket connection and attempting reconnect (org.apache.zookeeper.ClientCnxn)
java.net.ConnectException:Connection refused
Make sure that Broker and ZK is up.
Created 03-02-2016 12:56 AM
Thanks Neeraj, It's working now.
Created 06-09-2016 06:04 PM
Hi Neeraj , why do we need to pass this parameter "borkerhost:6667"