Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 07-18-2016 02:41 AM
Unable to start zookeeper, getting following error:
Could not find or load main class org.apache.zookeeper.server.quorum.QuorumPeerMain
Created 07-18-2016 09:51 PM
Issue is resolved after deleting the zookeeper services and reinstalling. Unable to start the service due to improper configuration of the service.
Created 07-18-2016 03:33 AM
Just check if you are running into multinode cluster and facing timeout issue below:-
https://issues.apache.org/jira/browse/ZOOKEEPER-1213
If you are running single node what is the result of
./zookeeper/bin/zkServer.sh start
Created 07-18-2016 03:56 AM
nope it's not timeout issue, see my error its related to library issue I guess. Anyway here is the start output
# rm /var/run/zookeeper/zookeeper_server.pid rm: remove regular file `/var/run/zookeeper/zookeeper_server.pid'? y # /usr/hdp/2.3.2.0-2950/zookeeper/bin/zkServer.sh start ZooKeeper JMX enabled by default Using config: /usr/hdp/2.3.2.0-2950/zookeeper/bin/../conf/zoo.cfg Starting zookeeper ... STARTED # cat /var/run/zookeeper/zookeeper_server.pid 8760# ps -ef|grep 8760 root 8876 27093 0 23:53 pts/9 00:00:00 grep 8760 # /usr/hdp/2.3.2.0-2950/zookeeper/bin/zkServer.sh status ZooKeeper JMX enabled by default Using config: /usr/hdp/2.3.2.0-2950/zookeeper/bin/../conf/zoo.cfg Error contacting service. It is probably not running.
cat /var/log/zookeeper/zookeeper.out Error: Could not find or load main class org.apache.zookeeper.server.quorum.QuorumPeerMain
Created 07-18-2016 09:51 PM
Issue is resolved after deleting the zookeeper services and reinstalling. Unable to start the service due to improper configuration of the service.