Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (1)
avatar

Issue:

After enabling Kerberos with option 'Manage Kerberos principals and keytabs manually', adding a new component will not respond. This is due to a bug in Ambari 2.2. Refer link. Below is the error message reported on the web console

Error: http://{ambari-server}:8080/api/v1/clusters/{cluster_name}/services/KERBEROS?fields=Services/attribu...

Workaround:

Add KERBEROS service via API as below and try installing the component and then remove the KERBEROS service

1. Run the below curl command on the ambari-server (Enable admin user if disabled)

curl -H "X-Requested-By:ambari" -u admin:admin -i -X POST http://<ambari-server-host>:8080/api/v1/clusters/<cluster-name>/services/KERBEROS 

2. Add the new component which was failing before with the above error using Add service wizard

3. Once the installation is complete you can remove the service Kerberos using the below curl command

curl -H "X-Requested-By:ambari" -u admin:admin -i -X DELETE http://<ambari-server-host>:8080/api/v1/clusters/<cluster-name>/services/KERBEROS
1,049 Views
Version history
Last update:
‎12-28-2016 10:25 AM
Updated by:
Contributors