Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st. We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here. Need help or have questions? Drop us a line at [email protected]
18 May 2017 07:56:33,754 WARN [ambari-client-thread-26] PermissionHelper:78 - Error occurred when cluster or view is searched based on resource id
java.lang.NullPointerException
at org.apache.ambari.server.security.authorization.PermissionHelper.getPermissionLabels(PermissionHelper.java:74)
18 May 2017 07:56:33,975 ERROR [ambari-client-thread-26] ContainerResponse:419 - The RuntimeException could not be mapped to a response, re-throwing to the HTTP container
com.google.common.cache.CacheLoader$InvalidCacheLoadException: CacheLoader returned null for key 58.
at com.google.common.cache.LocalCache$Segment.getAndRecordStats(LocalCache.java:2348)
at com.google.common.cache.LocalCache$Segment.loadSync(LocalCache.java:2318)
at com.google.common.cache.LocalCache$Segment.lockedGetOrLoad(LocalCache.java:2280)
18 May 2017 07:56:33,977 WARN [ambari-client-thread-26] ServletHandler:561 - Error Processing URI: /api/v1/users/admin - (com.google.common.cache.CacheLoader$InvalidCacheLoadException) CacheLoader returned null for key 58.
18 May 2017 07:56:33,977 WARN [ambari-client-thread-26] ServletHandler:561 - Error Processing URI: /api/v1/users/admin - (com.google.common.cache.CacheLoader$InvalidCacheLoadException) CacheLoader returned null for key 58.
ROOT CAUSE:-
Zeppelin View is removed from ambari 2.5 but looks like a reference stays there.
SOLUTION:-
Check this by running the following query on ambari DB.
# psql -U ambari ambari
Password for user ambari: bigdata
psql => command
-U ambari => is the username
ambari => is the DB name
It will ask for password, Where we can try using the ambari's default password as "bigdata"
If the password is changed then we can check the file.
So please get the "resource_id" of Zeppelin View if present?(In my case it is 58)
# select * from adminresourcetype;
# select * from adminresourcetype; where resource_type_id IN (select resource_type_id from adminresource where resource_id =58);
If that is the case then please Take Ambari DB Dump and then run the following commands to clean the Zeppelin View reference:
# psql -U ambari ambari
Password for user ambari: bigdata
# DELETE FROM adminprivilege where resource_id in(58);
# DELETE FROM adminresource where resource_id in(58);