Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (2)
avatar
Super Guru

SYMPTOM: Ambari smoke test fails for hbase service. Below is the current scenario -

  • Ranger is installed in the cluster
  • HBase policy has been enabled
  • ambari-qa user has the privileges correctly defined in the HBase policy

ERROR:

ERROR: org.apache.hadoop.hbase.security.AccessDeniedException: Insufficient permissions (user=ambari-qa, scope=default, params=[namespace=default,table=default:ambarismoketest,family=family],action=CREATE)

2015-10-27 09:52:03,342 ERROR [main] client.AsyncProcess: Failed to get region location 
org.apache.hadoop.hbase.TableNotFoundException: Table 'ambarismoketest' was not found, got: XXXXX01.

ROOT CAUSE:

If the Ranger co-processor is not correctly defined in the HBase configuration, the smoke test from Ambari would fail. Any table creation as non-hbase user could also fail.

RESOLUTION:

Verify the Ranger configuration for HBase. Ensure that the following properties are set correctly and that the co-processors include Ranger classes

hbase.coprocessor.master.classes
hbase.coprocessor.region.classes
hbase.coprocessor.regionserver.classes

All of the above should include org.apache.ranger.authorization.hbase.RangerAuthorizationCoprocessor

hbase.security.authorization should be enabled i.e. set to true.

2,082 Views
Version history
Last update:
‎12-23-2016 05:34 AM
Updated by:
Contributors