Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st. We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here. Need help or have questions? Drop us a line at [email protected]
SYMPTOM: Ambari smoke test fails for hbase service. Below is the current scenario -
Ranger is installed in the cluster
HBase policy has been enabled
ambari-qa user has the privileges correctly defined in the HBase policy
ERROR:
ERROR: org.apache.hadoop.hbase.security.AccessDeniedException: Insufficient permissions (user=ambari-qa, scope=default, params=[namespace=default,table=default:ambarismoketest,family=family],action=CREATE)
2015-10-27 09:52:03,342 ERROR [main] client.AsyncProcess: Failed to get region location
org.apache.hadoop.hbase.TableNotFoundException: Table 'ambarismoketest' was not found, got: XXXXX01.
ROOT CAUSE:
If the Ranger co-processor is not correctly defined in the HBase configuration, the smoke test from Ambari would fail. Any table creation as non-hbase user could also fail.
RESOLUTION:
Verify the Ranger configuration for HBase.
Ensure that the following properties are set correctly and that the co-processors include Ranger classes