Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (1)
avatar
Contributor

PROBLEM : Ambari Workflow Manager view with kerberos fails to clear Oozie Service Check and errors out with proxy error in wfmanager-view.log.

ERROR :

11 May 2017 22:34:49,839  INFO [ambari-client-thread-26] [WORKFLOW_MANAGER 1.0.0 MyWFM] OozieDelegate:149 - Proxy request for url: [GET] http://space2.example.com:11000/oozie/v1/admin/configuration
11 May 2017 22:34:49,889 ERROR [ambari-client-thread-26] [WORKFLOW_MANAGER 1.0.0 MyWFM] OozieProxyImpersonator:456 - Error in GET proxyjava.lang.RuntimeException:
java.lang.NullPointerException
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1455)
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1441)
	at sun.net.www.protocol.http.HttpURLConnection.getHeaderField(HttpURLConnection.java:2979)
	at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:489)

ROOT CAUSE : Missing below properties in custom oozie-site.xml.

oozie.service.ProxyUserService.proxyuser.<AMBARI_SERVER_PRINCIPAL_USER>.hosts=*
oozie.service.ProxyUserService.proxyuser.<AMBARI_SERVER_PRINCIPAL_USER>.groups=*

WORKAROUND / RESOLUTION :

Update below property in Oozie configs for Custom oozie-site.xml via Ambari UI and make the value to *:

oozie.service.ProxyUserService.proxyuser.<AMBARI_SERVER_PRINCIPAL_USER>.hosts=*
oozie.service.ProxyUserService.proxyuser.<AMBARI_SERVER_PRINCIPAL_USER>.groups=*

Please restart the Oozie service and try accessing hive view from standalone view server.

Also make sure for Kerberized Ambari and HDP, in Ambari WORKFLOW_MANAGER view definition, you've WebHDFS Authorization as "auth=KERBEROS;proxyuser=<AMBARI_SERVER_PRINCIPAL_USER>" instead of "auth=SIMPLE".

More reference can be found HERE.

2,097 Views
Version history
Last update:
‎05-12-2017 01:59 AM
Updated by:
Contributors