Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st. We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here. Need help or have questions? Drop us a line at [email protected]
After updating from CM 7.6.1 to CM 7.7.1, we are unable to connect the multiple PQS with the KNOX using the ODBC, Always getting the 500 error. But there is no issues when we are using the JDBC.
The cause of the issue is due to the topology change after the CM upgrade, for services such as HIVE and AVATICA.
--------------------------------------------------------------------------------------
from:
<value>enabled=true;maxFailoverAttempts=3;failoverSleep=1000;maxRetryAttempts=300;retrySleep=1000;</value>
to:
<value>enableStickySession=true;noFallback=true;enableLoadBalancing=true</value>
----------------------------------------------------------------------------------------
This is in order to support the Knox load balancer feature.
And we followed the below steps to revert the changes for existing cluster.
This article is contributed by an external user. The steps may not be verified by Cloudera and may not be applicable for all use cases and may be very specific to a particular distribution. Please follow with caution and at your own risk. If needed, raise a support case to get confirmation.