Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (2)
avatar

HDP Stack Version: 2.4.0

SYMPTOMS:

WARN Error while fetching metadata [{TopicMetadata for topic <topic-name> -> No partition metadatafor topic <topic-name> due to kafka.common.TopicAuthorizationException}] for topic <topic-name>: class kafka.common.TopicAuthorizationException (kafka.producer.BrokerPartitionInfo) 
.... 

ERROR Failed to collate messages by topic, partition due to: Failed to fetch topic metadata for topic: <topic-name> (kafka.producer.async.DefaultEventHandler) 

ROOT CAUSE: At the moment we can’t use user/group based access to authorize Kafka access over a non-secure channel. This is because it is not possible to assert client’s identity over the non-secure channel. It is ip based in a non-secure environment. Reference: https://cwiki.apache.org/confluence/display/RANGER/Kafka+Plugin See: Authorizing Kafka access over non-authenticated channel via Ranger RESOLUTION: The policy doesn't work if, IP address is not configured. This address will be of producer and consumer.

10729-kafka-policy.png

1,284 Views
0 Kudos
Version history
Last update:
‎08-17-2019 06:59 AM
Updated by:
Contributors