Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (2)
avatar
Expert Contributor

ISSUE : In Ambari 2.4.x, Falcon Web UI is inaccessible(HTTP 503 error) and Ambari Service Check for Falcon fails: "ERROR: Unable to initialize Falcon Client object"

Snippet of error from falcon logs

2017-01-04 14:08:56,390 INFO - [main:] ~ Initializing graph db (MetadataMappingService:143) 
2017-01-04 14:08:56,438 ERROR - [main:] ~ Failed startup of context org.mortbay.jetty.webapp.WebAppContext@96a75da{/,/usr/hdp/current/falcon-server/server/webapp/falcon} (log:87) 
Caused by: org.apache.falcon.FalconException: java.lang.RuntimeException: GraphFactory could not instantiate this Graph implementation [com.thinkaurelius.titan.core.TitanFactory]. 
Caused by: java.lang.RuntimeException: GraphFactory could not instantiate this Graph implementation [com.thinkaurelius.titan.core.TitanFactory]. 
Caused by: java.lang.reflect.InvocationTargetException 
Caused by: java.lang.NoClassDefFoundError: com/sleepycat/je/LockMode 
Caused by: java.lang.ClassNotFoundException: com.sleepycat.je.LockMode 
2017-01-04 14:08:56,440 INFO - [main:] ~ Started [email protected]:15000 (log:67) 

ROOT CAUSE : Missing jar

WORK AROUND :

On the falcon server, download missing jar and save it under falcon lib location

wget http://search.maven.org/remotecontent?filepath=com/sleepycat/je/5.0.73/je-5.0.73.jar -O /usr/hdp/current/falcon-server/server/webapp/falcon/WEB-INF/lib/je-5.0.73.jar


chown falcon:hadoop /usr/hdp/current/falcon-server/server/webapp/falcon/WEB-INF/lib/je-5.0.73.jar

Restart Falcon server from Ambari. Hortonworks cannot ship this jar. It has to be manually downloaded.

10,958 Views
Comments

Thanks I had same issue with HDP 2.6 upgrade. I was able to fix it after following the instructions.

thanks for the resolution. this resolved the falcon issue after upgrading to HDP-2.6.0.3 .

I just ran into the same issue in HDP 2.6.0 whose Ambari.repo content is:

#VERSION_NUMBER=2.5.0.3-7 [ambari-2.5.0.3] name=ambari Version - ambari-2.5.0.3 baseurl=http://public-repo-1.hortonworks.com/ambari/centos7/2.x/updates/2.5.0.3 gpgcheck=1 gpgkey=http://public-repo-1.hortonworks.com/ambari/centos7/2.x/updates/2.5.0.3/RPM-GPG-KEY/RPM-GPG-KEY-Jenkins enabled=1 priority=1

The work-around posted here fixed my issue.

Awesome. I faced this same problem in HDP 2.5, I was able to resolve it using the instructions mentioned in this post!

Version history
Last update:
‎01-05-2017 05:14 PM
Updated by:
Contributors