Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (2)
avatar
Super Guru

PROBLEM STATEMENT: There are frequent email alerts from HiveServer2 Metastore process which are misleading. When check the HiveServer2 Metastore process is up and running fine without issue.

ERROR: Below is sample email alert -

9569-screen-shot-2016-11-18-at-124144-pm.png

Ambari Alerts log output shows -

/var/log/ambari-server/ambari-alerts.log

9570-screen-shot-2016-11-18-at-123735-pm.png

ROOT CAUSE: The issue was with kerberos credentials for ambari-qa user.

RESOLUTION:

HiveServer2 Metastore alert is triggered from the node on which the service is installed. "ambari-qa" user is used by ambari to trigger the alert. If you are using kerberized cluster make sure you have "ambari-qa" ticket in place else false alert will be triggered.

You can use below command to check -

$su - ambari-qa 
$klist   <--[make sure you have valid ticket]

$hive --hiveconf hive.metastore.uris=thrift://<hive_mestastore_host>:9083 --hiveconf hive.metastore.client.connect.retry.delay=1 --hiveconf hive.metastore.failure.retries=1 --hiveconf hive.metastore.connect.retries=1 --hiveconf hive.metastore.client.socket.timeout=14 --hiveconf hive.execution.engine=mr -e 'show databases;' 

Also check, sometimes you might hit - https://issues.apache.org/jira/browse/AMBARI-14424

598 Views
Version history
Last update:
‎08-17-2019 08:03 AM
Updated by:
Contributors