Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st. We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here. Need help or have questions? Drop us a line at [email protected]
After Kerberos has been enabled, I was not able to open Hive View from Ambari.
I would get the following error message:
Issue detected
Service 'userhome' check failed: Usernames not matched: name=root != expected=ambari-server-<clusterName>
Service 'userhome' check failed:
java.io.IOException: Usernames not matched: name=root != expected=ambari-server-<clusterName>
at sun.reflect.GeneratedConstructorAccessor248.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
Root cause
Ambari server is running as root so it tries to authenticate with a proxy user as 'root' where as the ambari.service.keytab expects a principal as ambari-server-<clusterName>@REALM. Hence the mismatch.