Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st. We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here. Need help or have questions? Drop us a line at [email protected]
Created on 07-09-202308:31 PM - edited on 04-20-202611:51 PM by GrazittiAPI
When starting NiFi, it uses the default staging path which is /home/NiFi/. This path needs the Execute permissions for NiFi binaries to avoid NiFi from failing to starting . The below error would also indicate the cause of this issue;
Caused by: java.lang.UnsatisfiedLinkError: /home/nifi/.cache/JNA/temp/jna3526468256198020468.tmp: /home/nifi/.cache/JNA/temp/jna3526468256198020468.tmp: failed to map segment from shared object: Operation not permitted
Solution
In case of security hardening (noexec) for /home, you need to change the default staging directory in NiFi by using the below parameters:
CM > NIFI > Configs
NiFi Node Advanced Configuration Snippet (Safety Valve) for staging/bootstrap.conf.xml
add the following: Name: java.arg.jna Value: -Djna.tmpdir=/NEWPATH