Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (2)
avatar

Issue:

When you are trying to run queries from Tableau, SQuirrel etc.. connecting to Hiveserver2 via JDBC/ODBC driver in a Knox environment, you might intermittently come across the above error. This error pops-up especially when the query has more columns in the select statement. Interestingly, the same query works fine from hive cli and beeline cli.

Resolution:

This is a bug in Knox - https://issues.apache.org/jira/browse/KNOX-492

Log into Ambari > Knox > Config > Add the below under "Advanced Topology" file section

<service>
         <role>HIVE</role>
         <url>http://localhost:10001/cliservice</url>
         <param>
             <name>replayBufferSize</name>
             <value>16</value>
         </param>
</service>
5,862 Views
Comments
avatar

I wrote about this a while back not really a bug anymore but more of default setting that needs to be adjusted based on data being passed. see https://community.hortonworks.com/articles/33875/knox-queries-fail-quickly-with-a-500-error.html

Version history
Last update:
‎12-27-2016 03:01 PM
Updated by:
Contributors