Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st. We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here. Need help or have questions? Drop us a line at [email protected]
Created on 12-31-201607:34 PM - edited 08-17-201906:20 AM
Error:
ERROR [2016-12-13 00:48:04,166] ({pool-2-thread-2} Job.java[run]:189) - Job failed
java.lang.NoClassDefFoundError: org/apache/hadoop/security/UserGroupInformation$AuthenticationMethod
at org.apache.zeppelin.jdbc.security.JDBCSecurityImpl.getAuthtype(JDBCSecurityImpl.java:66)
....
Caused by: java.lang.ClassNotFoundException: org.apache.hadoop.security.UserGroupInformation$AuthenticationMethod
at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
... 15 more
Solution:
For systems in hdp cluster with no internet access local-repo folder doesnt get created when running zeppelin interpreters which hold the jar files needed for the interpreters.
To circumvent this we would need to copy the following jars to a temporary location and then specify these in the interpreter setting from zeppelin UI
create and copy all required jars to following "/usr/hdp/current/zeppelin-server/jarss/"
/usr/hdp/current/zeppelin-server/jarss/hive-jdbc-2.0.1-standalone.jar
/usr/hdp/current/zeppelin-server/jarss/hadoop-common-2.7.3.2.5.0.0-1245.jar
/usr/hdp/current/zeppelin-server/jarss/hive-shims-0.23-2.1.0.2.5.0.0-1245.jar
/usr/hdp/current/zeppelin-server/jarss/commons-configuration-1.10.jar
/usr/hdp/current/zeppelin-server/jarss/hadoop-auth-2.7.3.2.5.0.0-1245.jar
/usr/hdp/current/zeppelin-server/jarss/curator-client-2.7.1.jar
/usr/hdp/current/zeppelin-server/jarss/curator-framework-2.7.1.jar
/usr/hdp/current/zeppelin-server/jarss/zookeeper-3.4.6.2.5.0.0-1245.jar
/usr/hdp/current/zeppelin-server/jarss/commons-lang3-3.3.2.jar
Specify the complete path to the jar under Zeppelin UI --> Interpreter --> Jdbc
/usr/hdp/current/zeppelin-server/jarss/ is the temporary location these jars are copied to? Then this path needs to be specified in Zeppelin UI --> Interpreter --> Jdbc --> zeppelin.interpreter.localRepo?