Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st. We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here. Need help or have questions? Drop us a line at [email protected]
Created on 12-24-201612:56 PM - edited on 02-17-202009:28 AM by VidyaSargur
ENVIRONMENT: HDP 2.5.0 , Ambari 2.4.1
ERRORS:- Logs from Ambari server:-
resource_management.core.exceptions.ExecutionFailed: Execution of 'ambari-sudo.sh su hdfs -l -s /bin/bash -c 'ulimit -c unlimited ; /usr/hdp/2.5.3.0-37/hadoop/sbin/hadoop-daemon.sh --config /usr/hdp/2.5.3.0-37/hadoop/conf start namenode -rollingUpgrade started'' returned 1. -bash: line 0: ulimit: core file size: cannot modify limit: Operation not permitted
starting namenode, logging to /var/log/hadoop/hdfs/hadoop-hdfs-namenode-llab90hdpc2m3.out
ROOT CAUSE:- Not yet known,reported as Internal bug. (BUG-70647)
WORKAROUND:- Add the following entries to /etc/security/limits.conf to complete the upgrade.
soft core unlimited
hard core unlimited
OR as root user, run the following command on Ambari server host.
ulimit -c unlimited
Please note that its not a recommended setting for any of the HDP components and just a workaround to complete the upgrade. Please revert the setting afterwards.In case unsure of the execution/implications of this step ,please raise a support case with HWX to assist further.