Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (1)
avatar

"Error executing: call add_columns_to_support_audit_log_aggregation();

java.sql.SQLException: Incorrect key file for table 'xa_access_audit'; try to repair it

SQLException : SQL state: HY000 java.sql.SQLException: Incorrect key file for table 'xa_access_audit'; try to repair it ErrorCode: 1034

2016-04-11 06:05:59,187 [E] 015-auditlogaggregation.sql import failed!"

SOLUTION:

Make sure you have enough space in the /tmp directory and take the backup of 'xa_access_audit' as below.

Login to MySQL.

use ranger_audit;

create table xa_access_audit_backup as select * from 'xa_access_audit' ;

truncate table xa_access_audit_backup;

and retry the upgrade.

958 Views
Version history
Last update:
‎04-11-2016 01:56 PM
Updated by:
Contributors