Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (1)
avatar
Rising Star

Affected versions:

SmartSense 1.3.x

Symptoms:

Gateway start fails with following exception in hst-gateway.log :

INFO 2016-10-21 12:32:42,881
hst-gateway.py:520 - SmartSense Gateway is not running... INFO 2016-10-21 12:32:42,882
hst-gateway.py:539 - Running server: ['/bin/sh', '-c', 'ulimit -n 10000;
/usr/java/default/bin/java -server -XX:NewRatio=3 -XX:+UseConcMarkSweepGC
-XX:-UseGCOverheadLimit -XX:CMSInitiatingOccupancyFraction=60 -Dlog.file.name=hst-gateway.log
-Xms512m -Xmx1024m -cp /etc/hst/conf:/usr/hdp/share/hst/hst-common/lib/*
com.hortonworks.smartsense.gateway.server.GatewayServer
>/var/log/hst/hst-gateway.out 2>&1 &'] 
INFO 2016-10-21 12:32:42,884 hst-gateway.py:542 - Executing Gateway Server start command 
21 Oct 2016 12:32:43,505 DEBUG main GatewayConfigValidator:40 - Found supported transfer type:HTTPS 
21 Oct 2016 12:32:43,507 INFO main GatewayConfigValidator:67 - Found configurations to be used for connectivity. 
21 Oct 2016 12:32:43,509 INFO main GatewayValidator:149 - Trying to reach: smartsense-dev.hortonworks.com:443 
21 Oct 2016 12:32:43,667 ERROR main GatewayValidator:93 - Failed to reach SmartSense landing zone host:smartsense-dev.hortonworks.com, port:443 
21 Oct 2016 12:32:43,667 INFO main GatewayValidator:149 - Trying to reach: hortonworks.com:80 
21 Oct 2016 12:32:43,678 ERROR main GatewayValidator:100 - Failed to reach hortonworks.com:80. 
21 Oct 2016 12:32:43,679 ERROR main GatewayServer:78 - Error occured during Gateway Server Setup. Unable to start Gateway Server. com.hortonworks.smartsense.gateway.GatewayException:
Unable to reach hortonworks.com:80. Please verify outbound connectivity on Gateway. 
at com.hortonworks.smartsense.gateway.server.GatewayValidator.validateReachable(GatewayValidator.java:102)
at
com.hortonworks.smartsense.gateway.server.GatewayValidator.validateSetup(GatewayValidator.java:65)at com.hortonworks.smartsense.gateway.server.GatewayServer.run(GatewayServer.java:99)
at com.hortonworks.smartsense.gateway.server.GatewayServer.main(GatewayServer.java:76)

Caused by:
java.net.ConnectException: Connection refused 
at java.net.PlainSocketImpl.socketConnect(Native Method) 
at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350) 
at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188) 
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) 
at java.net.Socket.connect(Socket.java:589)
at com.hortonworks.smartsense.gateway.server.GatewayValidator.isReachable(GatewayValidator.java:150)
at com.hortonworks.smartsense.gateway.server.GatewayValidator.validateReachable(GatewayValidator.java:90)... 3 more

Reason:

There is a gateway validation process that checks for outbound connectivity during start up. This validation test was trying an outbound socket connectivity check without passing through the proxy and failing.

Solution:

Fixed in SmartSense 1.4.0. Please upgrade to this version and restart Gateway to automatically fix the issue. Gateway supports backward compatibility where HST 1.2.x or HST 1.3.x can use the Gateway 1.4.0 to upload bundles. Otherwise, for 1.3.x set the property in /etc/hst/conf/hst-gateway.ini in gateway section and restart Gateway:

start.validation.enabled=false
2,889 Views
Version history
Last update:
‎04-27-2017 11:55 PM
Updated by:
Contributors