Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (1)
avatar
Rising Star

Issue:

Solr service check fails from ambari when Namenode HA is enabled with error:

Unable to create core [collection1_shard2_replica1] Caused by: Connection refused

Solution 1:

add this line "SOLR_HDFS_CONFIG=/etc/hadoop/conf" to solr-config-env content at the end of file

Restart Solr and now the service checks should pass.

Solution 2:

Another workaround is to edit the following file on your Ambari Server: /var/lib/ambari-server/resources/mpacks/solr-ambari-mpack-5.5.2.2.5/common-services/SOLR/5.5.2.2.5/package/scripts/solr.py, and then make this change: https://github.com/lucidworks/solr-stack/commit/7b79894b37b862b86d80c64b34230bc9fed6e54a.

Then restart the Ambari Server. With this change in place the Solr instances will be started and will work fine with NN HA.

This will be fixed in HDP 2.6

1,396 Views
Version history
Last update:
‎12-31-2016 08:21 PM
Updated by:
Contributors