Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (1)
avatar
Expert Contributor

PROBLEM

Running sqoop import command in direct mode for accessing a Netezza data warehouse appliance hangs at 100% map

sqoop import --options-file sqoop_opts_file.opt
.
.
.
INFO mapreduce.Job: Running job: job_1465914632244_0005
INFO mapreduce.Job: Job job_1465914632244_0005 running in uber mode : false
INFO mapreduce.Job:  map 0% reduce 0%
INFO mapreduce.Job:  map 25% reduce 0%
INFO mapreduce.Job:  map 50% reduce 0%
INFO mapreduce.Job:  map 100% reduce 0%

The sqoop_opts_file.opt had the following options :

-connect
jdbc:netezza://xxxxxxxxxxxxxxxxxxxxxx:5480/
--username
XXXX 
--password
***************
--direct
--direct-split-size
1000000
--compress
--table
table_name
--target-dir
/user/root/table_name
--verbose

Yarn logs show the below errors

ERROR [Thread-14] org.apache.sqoop.mapreduce.db.netezza.NetezzaJDBCStatementRunner: Unable to execute external table export
org.netezza.error.NzSQLException: ERROR:  found delim ',' in a data field, specify escapeChar '\' option in the external table definition
RESOLUTION :

Add --input-escaped-by '\' parameter to sqoop command and then run the command

1,858 Views
0 Kudos
Version history
Last update:
‎12-22-2016 03:13 PM
Updated by:
Contributors