Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st. We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here. Need help or have questions? Drop us a line at [email protected]
In HDP 2.3.4 and Ambari 2.4.2, Storm nimbus was not coming up:
2017-05-30 14:35:18.756 o.a.t.s.TThreadPoolServer [ERROR] Error occurred during processing of message.
java.lang.RuntimeException: No nimbus leader participant host found, have you started your nimbus hosts??
Following is the error from Nimbus log:
2017-05-30 14:35:18.750 b.s.d.nimbus [WARN] principal: [email protected] is trying to impersonate principal: [email protected]
2017-05-30 14:35:18.751 b.s.d.nimbus [WARN] impersonation attempt but nimbus.impersonation.authorizer has no authorizer configured. potential
security risk, please see SECURITY.MD to learn how to configure impersonation authorizer.
2017-05-30 14:35:18.756 o.a.t.s.TThreadPoolServer [ERROR] Error occurred during processing of message.
java.lang.RuntimeException: No nimbus leader participant host found, have you started your nimbus hosts?
Cause:
Property ''nimbus.impersonation.authorizer" was set to 'org.apache.storm.security.auth.authorizer.ImpersonationAuthorizer'. Prior to HDP 2.5, the storm package was backtype instead of org.apache.