Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st. We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here. Need help or have questions? Drop us a line at [email protected]
Storm Service Check fails with a Kerberos error after performing an Ambari upgrade in a cluster that had Metron installed.
Article
In a cluster where Metron was removed before upgrading Ambari server, the following error can occur when performing a Service Check in Storm service:
Exception in thread "main" java.lang.RuntimeException: java.lang.RuntimeException: The TGT found is not renewable
at org.apache.storm.security.auth.kerberos.AutoTGT.populateCredentials(AutoTGT.java:1)
at org.apache.storm.StormSubmitter.populateCredentials(StormSubmitter.java:3)
at org.apache.storm.StormSubmitter.submitTopologyAs(StormSubmitter.java:748)
at org.apache.storm.StormSubmitter.submitTopology(StormSubmitter.java:590)
at org.apache.storm.StormSubmitter.submitTopology(StormSubmitter.java:239)
at storm.starter.WordCountTopology.main(WordCountTopology.java:492)
Caused by: java.lang.RuntimeException: The TGT found is not renewable
at org.apache.storm.security.auth.kerberos.AutoTGT.populateCredentials(AutoTGT.java:291)
Solution
Go to Ambari -> Storm Service -> Configs -> Custom storm-site and remove the following properties: