Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st. We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here. Need help or have questions? Drop us a line at [email protected]
2017-06-09 14:40:18.348 o.a.s.d.supervisor [ERROR] Error on initialization of server mk-supervisor
java.lang.RuntimeException: java.lang.ClassNotFoundException: backtype.storm.generated.LSSupervisorId
at org.apache.storm.utils.LocalState.deserialize(LocalState.java:83)
at org.apache.storm.utils.LocalState.get(LocalState.java:130)
at org.apache.storm.local_state$ls_supervisor_id.invoke(local_state.clj:61)
at org.apache.storm.daemon.supervisor$standalone_supervisor$reify__7977.prepare(supervisor.clj:1216)
at org.apache.storm.daemon.supervisor$fn__7833$exec_fn__3537__auto____7834.invoke(supervisor.clj:766)
at clojure.lang.AFn.applyToHelper(AFn.java:160)
at clojure.lang.AFn.applyTo(AFn.java:144)
at clojure.core$apply.invoke(core.clj:630)
at org.apache.storm.daemon.supervisor$fn__7833$mk_supervisor__7878.doInvoke(supervisor.clj:764)
at clojure.lang.RestFn.invoke(RestFn.java:436)
at org.apache.storm.daemon.supervisor$_launch.invoke(supervisor.clj:1204)
at org.apache.storm.daemon.supervisor$_main.invoke(supervisor.clj:1237)
at clojure.lang.AFn.applyToHelper(AFn.java:152)
at clojure.lang.AFn.applyTo(AFn.java:144)
at org.apache.storm.daemon.supervisor.main(Unknown Source)
Caused by: java.lang.ClassNotFoundException: backtype.storm.generated.LSSupervisorId
at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:335)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:264)
at org.apache.storm.utils.LocalState.deserialize(LocalState.java:78)
... 14 more
2017-06-09 14:40:18.351 o.a.s.util [ERROR] Halting process: ("Error on initialization")
java.lang.RuntimeException: ("Error on initialization")
at org.apache.storm.util$exit_process_BANG_.doInvoke(util.clj:341)
at clojure.lang.RestFn.invoke(RestFn.java:423)
at org.apache.storm.daemon.supervisor$fn__7833$mk_supervisor__7878.doInvoke(supervisor.clj:764)
at clojure.lang.RestFn.invoke(RestFn.java:436)
at org.apache.storm.daemon.supervisor$_launch.invoke(supervisor.clj:1204)
at org.apache.storm.daemon.supervisor$_main.invoke(supervisor.clj:1237)
at clojure.lang.AFn.applyToHelper(AFn.java:152)
at clojure.lang.AFn.applyTo(AFn.java:144)
at org.apache.storm.daemon.supervisor.main(Unknown Source)
Cause:
1. Few storm configs were still configured with backtype packages
2. Stale states in zookeeper and local data
Solution:
1. Filtered in the configs and changed all the backtype packages to org.apache as Storm from HDP 2.5 onwards uses org.apache packages.
2. Follow below steps to clear stale states and local data:
-> Deactivate all running topologies.
-> Stop Storm service
-> Delete all states under zookeeper: