Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (1)
avatar

ENVIRONMENT: HDP 2.5 with RM in HA.

SYMPTOMS:

gaurav@g1:~> hadoop jar /usr/hdp/2.5.0.0-1245/hadoop-mapreduce/hadoop-mapreduce-examples.jar pi 5 8 
Number of Maps = 5
amples per Map = 8 
Wrote input for Map #0 
Wrote input for Map #1 
Wrote input for Map #2 
Wrote input for Map #3 
Starting Job 
11/02/16 12:20:01 INFO impl.TimelineClientImpl: Timeline service address: http://g1.openstacklocal:8188/ws/v1/timeline
/11/02/16 12:20:02 INFO client.AHSProxy: Connecting to Application History server at /0.0.0.0:10200 
11/02/16 12:20:05 WARN ipc.Client: Failed to connect to server: g2.openstacklocal:8032: retries get failed due to exceeded maximum allowed retries number: 0 java.net.ConnectException: Connection refused at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)

ROOT CAUSE: This a known behavior reported in internal jira BUG-65968.This is not a problem but an expected behavior.No matter which RM is currently active, the application would always try to connect to the rm1, then rm2. Please note that this message is just a warning and wont affect the job run in any way.

5,250 Views
0 Kudos
Comments
avatar

Is this bug resolved:BUG-65968, what the current status?

avatar
New Member

Hi,

Why this bug is coming only in HDP 2.5.If we have both 2.5 and 2.4 version.But this error is coming only in hdp 2.5.3 Is this a bug by yarn or HDP. Is there a workaround.

avatar
Expert Contributor

Is there any config parameter to make it shorter failing over to rm2?

Is below config parameter effective on this procedure?

yarn.resourcemanager.connect.retry-interval.ms=30000

Version history
Last update:
‎12-27-2016 05:22 PM
Updated by:
Contributors