Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (2)
avatar
Rising Star

Error:

%jdbc (Hive) 

java.util.ServiceConfigurationError: javax.xml.parsers.DocumentBuilderFactory: Provider org.apache.xerces.jaxp.DocumentBuilderFactoryImpl not found 
at java.util.ServiceLoader.fail(ServiceLoader.java:239) 
at java.util.ServiceLoader.access$300(ServiceLoader.java:185) 
at java.util.ServiceLoader$LazyIterator.nextService(ServiceLoader.java:372) 
at java.util.ServiceLoader$LazyIterator.next(ServiceLoader.java:404) at java.util.ServiceLoader$1.next(ServiceLoader.java:480) 
at javax.xml.parsers.FactoryFinder$1.run(FactoryFinder.java:294) 
at java.security.AccessController.doPrivileged(Native Method) 
at javax.xml.parsers.FactoryFinder.findServiceProvider(FactoryFinder.java:289) 
at javax.xml.parsers.FactoryFinder.find(FactoryFinder.java:267) 
at javax.xml.parsers.DocumentBuilderFactory.newInstance(DocumentBuilderFactory.java:120) 
at org.apache.hadoop.conf.Configuration.loadResource(Configuration.java:2549) 
at org.apache.hadoop.conf.Configuration.loadResources(Configuration.java:2526) 
at org.apache.hadoop.conf.Configuration.getProps(Configuration.java:2418) 
at org.apache.hadoop.conf.Configuration.set(Configuration.java:1143) 
at org.apache.hadoop.conf.Configuration.set(Configuration.java:1115)

SOLUTION:

Copy the following jars : xercesImpl*.jar and xml-apis*

For eg:

Can be found by running

locate xercesImpl* on any of the node in he cluster

copy

/usr/hdp/<hadoop-version>/hadoop/client/xercesImpl-2.9.1.jar

to: /usr/hdp/current/zeppelin-server/interpreter/jdbc/

Restart the interpreter

2,209 Views
Version history
Last update:
‎12-31-2016 07:05 PM
Updated by:
Contributors