New Contributor
Posts: 1
Registered: ‎01-20-2016

Hue: Sqooping data with Oozie -> Unable to run Sqoop action

Hey guys,


I have CDH 5.5 version. I tried to submit the Sqoop job from the command line and it works:


sqoop import --connect jdbc:mysql://localhost/dblearning --username root -P --hbase-create-table --hbase-table "LA_AgilityRate"  --column-family "agilityrate" --table "AgilityRate" --split-by "studentid"


I added the mysql connector to both var/lib/sqoop/ and /user/oozie/share/lib/lib-XXX/sqoop/


but when I tried to create a workflow using the Oozie editor + Hue I got this error message:


<<< Invocation of Main class completed <<<

Failing Oozie Launcher, Main class [org.apache.oozie.action.hadoop.SqoopMain], exit code [1]

Oozie Launcher failed, finishing Hadoop job gracefully

Oozie Launcher, uploading action data to HDFS sequence file: hdfs://localhost:8020/user/bdata/oozie-oozi/0000001-160120113911045-oozie-oozi-W/sqoop-9c97--sqoop/a...

Do you know how to solve this error?




Posts: 1,903
Kudos: 435
Solutions: 307
Registered: ‎07-31-2013

Re: Hue: Sqooping data with Oozie -> Unable to run Sqoop action

Can you check/post the full stdout/stderr/syslog of the single map task on the Oozie launcher job ID? It would reveal more clearly what the actual reason of the failure is.

P.s. You do not need quotes if you are using the singular command syntax in Oozie to specify the sqoop command arguments. The quotes are only needed in shells when there's embedded spaces or escapes, but in Oozie this wouldn't be parsed in the same way (they'll be taken as literals).