Reply
Highlighted
Expert Contributor
Posts: 139
Registered: ‎07-21-2014

Sqoop import failing with "Check that JARs for hive datasets are on the classpath"

When using "--as-parquetfile" option to do "--hive-import", I'm running into this error:

 

org.kitesdk.data.DatasetNotFoundException: Unknown dataset URI pattern: dataset:hive://<metastore>:9083/<table>
Check that JARs for hive datasets are on the classpath

 

I've also passed the options to set the HIVE_HOME and HCAT_HOME:

 

             --hive-home
             /opt/cloudera/parcels/CDH/lib/hive
             --hcatalog-home
             /opt/cloudera/parcels/CDH/lib/hive-hcatalog

 

Is there anything else that need to be provided to the sqoop action in oozie?

 

Thanks!

 

Announcements
New solutions