Support Questions
Find answers, ask questions, and share your expertise

ATSv2 HBase Application The HBase application reported a 'FAILED' state. Check took Xs

Contributor

I have a small cluster running HDP 3.1.5.6091 with Ambari 2.7.5.0 the I inherited

The Yarn Timeline service starts but gets a constant critical alert

 

ATSv2 HBase Application The HBase application reported a 'FAILED' state. Check took 2.261s

 

The hadoop-yarn-timelinereader.log shows 

failed on connection exception: org.apache.hbase.thirdparty.io.netty.channel.AbstractChannel$AnnotatedConnectException: Connection refused:server.name:17020

 

I added that port (17020) to the firewall on the server in question, restarted the Timeline Service V2.0 Reader service but still getting the same error.

 

Any suggestions would be appreciated

 

 

 

3 REPLIES 3

Master Collaborator

@wazzu62 ,

 

"Connection refused" errors usually means that the server is reachable but not accepting connections on that port. If it was a firewall issue you should've seen a "connection timeout" type of error.

 

This might mean that either (a) the service running on the target server is not actually running or (b) it has been configured with a different port.

 

Have you tried telneting into that port to check if it's open at all? Try this locally from the server and remotely from where the ATS is running.

 

Cheers,

André

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Community Manager

@wazzu62, have you tried @araujo's suggestions? Has the reply helped resolve your issue? If so, can you please mark the appropriate reply as the solution? It will make it easier for others to find the answer in the future. 



Regards,

Vidya Sargur,
Community Manager


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community:

Super Collaborator

Greetings @wazzu62 

 

We wish to check if you have reviewed @araujo ask for further checks on the concerned issue. If required, Change the Port for the ATS HBase from 17020 to any Value to see if the same helps, assuming the Port is configured to accept request.  

 

Regards, Smarak

; ;