Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

AWS HDC create cluster button grayed out

Hi all

I am new to HDC and I am trying to spin up my first cluster. I used the basic option to set up my controller and this worked ok.

For creating the cluster I followed the instructions here:

When I get to the "confirm cluster create" both the "save template" and "yes create cluster" are grayed out.

I think I must have done something wrong in the set-up but can't spot it, please help. My CLI JSON is attached hdc-cli.txt





Expert Contributor

@Sharon Kirkham

Looking at another json (same config, worked 2 days ago), all is the same, except for spot price (maybe check if it works by removing), and the ClusterAndAmbariPassword is empty (though maybe you have manually removed before publishing?).

To confirm, you have access/authority to provision resources on AWS also?

Hi Graham

Thanks for getting back to me so quickly. I did try with and without spot pricing enabled and there were no differences

I did include the Ambari password on the form I think it gets removed from the json for security purposes.

I am the administrator of our AWS resources and created the controller earlier this morning so I don't think that is an issue.

Do you know what checks are carried out in order for the buttons to be activated? Perhaps I can dig into these more.



Expert Contributor
@Sharon Kirkham

Exact same config, and it works fine.

The ssh key you are using is working ok, you can ssh onto an AWS host with it?

Hi Graham

I have just created 2 instances in the same VPC as the HDC cluster I am trying to create using my key-pair with identical security groups:

1) a standard AWS micro instance and I could ssh as ec2-user to that instance fine.

2) an instance using the "Launch more software" in the Hortonworks Data Cloud - HDP services AMI. I could ssh as cloudbreak user (as per Hortonworks instruction) with my key-pair.

I realise 2) is not how to commission hardware for HDC but I wanted to see if there was a difference with ssh as you suggested. From the instance overview the security groups look identical as do the inbound rules so I think the key-pair is good.



Expert Contributor
@Sharon Kirkham

Nothing obvious come to

- Re-cycle of the Cloud Controller

- Kill your browser, and re-try.

- Same issue for different Images (e.g. the Data Science image)?

- Same issue for different regions (or can you only provision on one region)?

- Reducing the size of the cluster?

Hi @Sharon Kirkham,

Can you try unchecking the first box and removing the email address? Or use an email address without a dash?

I tried creating a cluster using the same parameters as you provided and it worked, but for some reason I had problems (error message/buttons disabled) when entering the email address that you used. I wonder if "-" is unsupported for some reason.


I reported the issue so it should be fixed in a future release.

Hi Dominika

Using an email with no - in it sorted out the issue. Thanks alot. Moving on to the cluster create now...



By the way, since you are using my tutorial, please let me know if I can improve it in any way. Thanks!

Hi Dominika.

Your blog is excellent and was extremely useful thank you.

While I was digging around trying to solve this issue I did find a great description of the issues you might come across while creating the controller and clusters. It is worth adding a link to this excellent article in your blog.



Hi @Sharon Kirkham,

I'm glad that you found the blog post helpful. The link to the Troubleshooting section is already there in the beginning of the post, but in case it doesn't stand out (I guess it does not, since you didn't notice it) I added it again at the end.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.