Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Access is denied error while starting KAFKA first time

avatar
Frequent Visitor

I am getting following error. I correctly put the path in server.properties, zookeeper.properties and zoo.cfg

cmd>C:\kafka_2.11-2.0.0> .\bin\windows\kafka-server-start.bat .config\server.properties
Access is denied.
log4j:ERROR setFile(null,true) call failed.
java.io.FileNotFoundException: \logs\server.log (The system cannot find the path specified)

 

 

1 REPLY 1

avatar
Explorer

try this: open your cmd: change directory with : cd C:\kafka_2.11-2.0.0 

if you change directory you will do this

C:\kafka_2.11-2.0.0> bin\zookeeper-server-start.bat   config\zookeeper.properties

C:\kafka_2.11-2.0.0> bin\kafka-server-start.bat   config\server.properties

if you don't change directory do this.

>C:\kafka_2.11-2.0.0\bin\zookeper-server-start.bat  C:\kafka_2.11-2.0.0\config\zookeeper.properties

> C:\kafka_2.11-2.0.0\bin\kafka-server-start.bat   C:\kafka_2.11-2.0.0\config\server.properties