Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

Accessing Search with HUE



When I access solr/search from cdh quick start vm, I am getting the below error. this is happening randomly......It got fixed before when I restart the quickstart vm....but today is not up even after restart.......


solr and zookeper are both running. 


23/Oct/2017 08:00:24 -0700] middleware INFO Processing exception: <html><head><title>Apache Tomcat/6.0.53 - Error report</title><style><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;} {color : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP Status 404 - /solr/nfcap_s/admin/luke/h1><HR size="1" noshade="noshade"><p><b>type</b> Status report</p><p><b>message</b> <u>/solr/nfcap_s/admin/luke</u></p><p><b>description</b> <u>The requested resource is not available.</u></p><HR size="1" noshade="noshade"><h3>Apache Tomcat/6.0.53</h3></body></html> (error 404): Traceback (most recent call last):
File "/usr/lib/hue/build/env/lib/python2.6/site-packages/Django-1.6.10-py2.6.egg/django/core/handlers/", line 112, in get_response
response = wrapped_callback(request, *callback_args, **callback_kwargs)
File "/usr/lib/hue/build/env/lib/python2.6/site-packages/Django-1.6.10-py2.6.egg/django/db/", line 371, in inner
return func(*args, **kwargs)
File "/usr/lib/hue/desktop/libs/dashboard/src/dashboard/", line 108, in new_search
collection = Collection2(user=request.user, name=collections[0], engine=engine)
File "/usr/lib/hue/desktop/libs/dashboard/src/dashboard/", line 49, in __init__
'collection': self.get_default(user, name, engine),
File "/usr/lib/hue/desktop/libs/dashboard/src/dashboard/", line 140, in get_default
fields = self.fields_data(user, name, engine)
File "/usr/lib/hue/desktop/libs/dashboard/src/dashboard/", line 234, in fields_data
fields = api.schema_fields(name)
File "/usr/lib/hue/apps/search/src/search/", line 50, in schema_fields
return self.api.fields(collection)





The real issue is that the page url /solr/nfcap_s/admin/luke did not exist:: "HTTP Status 404 - /solr/nfcap_s/admin/luke".

Are you sure that Solr is up and running and collection you tried to access has been imported correctly?


sorry for the delay in response...but yes solr is up and running....i am able to open the solr admin page and query the collection I created. 






Can anyone help me in this regard? I checked the hue.ini file under /etc/hue/conf.empty/hue.ini and I see the below in the file 



# URL of the Solr Server

# Requires FQDN in solr_url if enabled
## security_enabled=false

## Query sent when no term is entered
## empty_query=*:*

Have you checked if page /solr/nfcap_s/admin/luke exists in Solr or not?

Again, it is 404, either Solr is not serving the page, or Hue requested a wrong page. What was the page in Hue that you tried to access and gave you the error? Can you share the screenshot please?

Can you please see why Hue requested page /solr/nfcap_s/admin/luke? Is it correct?
Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.