Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

Adding nodes to a cluster post creation via an Altus Configuration file


The scenario:

Working within Azure... 

I was able to deploy a cluster via an Altus Director Configuration File

The problem is that Altus is having some trouble connecting to the Cloudera Manager... 
When I tried to later add nodes, via Altus Web-UI, I get the following error: 

The questions:
1) Is this a bug or did I miss something in the configuration file?

2) As a work-around, can I add additional nodes via a new configuration file?


Thank you



Just found the feature in Altus that updates creds'. 
This issue is solved! 

View solution in original post


Rising Star

Hi GaryS,


(1) Can you verify connectivity between Director host and Cloudera Manager host (maybe try pinging Cloudera Manager from Director host). The Director server logs may also contain more information on why the connection validation failed. You can refer here to see how to access the server logs:


(2) Unfortunatly, nodes can only be added/removed through the UI, it can't be done via config files. Though in your case since Director server can't reach Cloudera Manager, it would fail regardless, since this connectivity is required to properly add nodes to a cluster.



Thanks for the quick reply. 

I'm now able to reliably reproduce the issue. And, workaround is minor... 

1) Create a cluster via Altus cloudera-director bootstrap-remote (note the Cloudera Manager password if set)

2) Login to the new Cloudera manager

3) Change the password

* Altus then can no longer communicate with Cloudera Manager *  (401 error)

Workaround to get Altus communicating with Cloudera Manager:
1) Change Cloudera Manager back to previosu
2) Altus can now communicate... 

Is there a way to update the user/pass Altus uses to communicate to Cloudera Manager? 
... there must be a property file somewhere? 





Just found the feature in Altus that updates creds'. 
This issue is solved! 

Super Collaborator

Hi GaryS,


Thanks for following up that you were able to resolve your issue!


For others, to clarify: If you change the username and password for Cloudera Manager (for example, from the default admin/admin), then you do need to update Altus Director with the new credentials. That way, Altus Director can continue to work with Cloudera Manager to do things like add new hosts to a cluster. There is an option in the dropdown for a deployment in Altus Director to update the credentials.


In case there is still a problem in communications, a workaround is to set Cloudera Manager (and Altus Director) back to admin/admin, then do what you need to do, and then switch Cloudera Manager back. There is in fact one scenario in Altus Director where this is necessary, which we're working on fixing.


To add to what Asif said about the ways to add a new cluster node through Director: Besides the UI, you can use the Altus Director server API as well. The UI is just a special client for the API, anyway. Visit http://yourdirectorhost.example:7189/api-console/ for an interactive (Swagger) console to experiment. You can also try using the Java or Python SDKs, available on GitHub.