Support Questions
Find answers, ask questions, and share your expertise

Advanced Update Attribute won't display correctly in NiFi version 1.12.1

Highlighted

Advanced Update Attribute won't display correctly in NiFi version 1.12.1

New Contributor

Hello,

I'm trying to make some modification in my Update Attributes processors on section Advanced in NiFi , but I'm not able to see properly the rules I created before making the upgrade from 1.11.4 to 1.12.1.

 

Same problem for a new processor added after upgrade.

All I can see is this:Nifi.PNG

2 REPLIES 2
Highlighted

Re: Advanced Update Attribute won't display correctly in NiFi version 1.12.1

Contributor

Hello Boenu,
Were you able to resolve this issue, please? We upgraded our NiFi deployment today and are facing the same issue (tested in Firefox and Chrome).

Kind regards,

Julius

EDIT: found the related JIRA issues, seems like there is no fix for it, just a workaround
https://issues.apache.org/jira/browse/NIFI-7849

https://issues.apache.org/jira/browse/NIFI-7870

Re: Advanced Update Attribute won't display correctly in NiFi version 1.12.1

Master Guru

@Boenu 

Beginning with Apache NiFi 1.12 a change was implemented that changed the default anonymous access to static resources to false.  This was done as part of https://issues.apache.org/jira/browse/NIFI-7170.
This change also added the ability to add an additional property to the nifi.properties file to restore the behavior to that of Apache NiFi 1.11 and older versions: 

nifi.security.allow.anonymous.authentication=true

 
The above restores previous behavior while work is done to change the how NiFi handles access to these static endpoints.  The following Jiras cover that work:
https://issues.apache.org/jira/browse/NIFI-7849
https://issues.apache.org/jira/browse/NIFI-7870

 

Hope this helps,

Matt

Don't have an account?