Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

Ambari AD Sync On Groups Not Working

Expert Contributor

I have synced AD users to Ambari and they all work. But i added a group in AD and assigned users their respective groups then re-sync Ambari with AD. It brings in the groups but it didn't link the users to their respective groups in Ambari. how do I link them since Ambari won't let you do it - add user to group function is greyed out.

Is it possible to just go into postgresql and delete all the ldap user entries and their groups from users and groups table respectively the resync afterwards?


Please see the following link. It will provide more explanation.

Doc link

View solution in original post


Expert Contributor

Finally found the fix:

  • I tried re-running the sync by using ambari-server sync-ldap —users users.txt and —groups groups.txt and this time it worked.

I was expecting the —all flag to work as it should since it takes in all users in AD and sync it to Ambari. Is this a bug?

Please see the following link. It will provide more explanation.

Doc link

New Contributor

We are having exactly the same issue - groups sit empty in ambari after syncing. @rgarcia's fix hasn't worked for us.

Hi Ben, Is there any useful information you could share on your failure that may help with debugging or finding an alternative?

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.