Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Ambari Blueprint doesn't configure the SmartSense ActiveAnalysis Admin password

Solved Go to solution

Ambari Blueprint doesn't configure the SmartSense ActiveAnalysis Admin password

Contributor

Hi,

When use Ambari Blueprint to auto install HDP2.5.0 including SmartSense, the ActivityAnalysis admin password is not configured by "default_password" in blueprint. The component is failed to start, and have to manually set the password.

9374-screen-shot-2016-11-11-at-202221.png

Ambari version is V2.4.1.0. This bug should be fixed.

Regards,

Wendell

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Ambari Blueprint doesn't configure the SmartSense ActiveAnalysis Admin password

Thanks wbu,

What version of Ambari are you using? I'm guessing 2.4.x

I created https://issues.apache.org/jira/browse/AMBARI-19155 on your behalf.

View solution in original post

7 REPLIES 7
Highlighted

Re: Ambari Blueprint doesn't configure the SmartSense ActiveAnalysis Admin password

Thanks wbu,

What version of Ambari are you using? I'm guessing 2.4.x

I created https://issues.apache.org/jira/browse/AMBARI-19155 on your behalf.

View solution in original post

Highlighted

Re: Ambari Blueprint doesn't configure the SmartSense ActiveAnalysis Admin password

Contributor

Hi @Alejandro Fernandez

Yes, All 2.4.x

I tried 2.4.0.1, 2.4.1, 2.4.2, all the same.

Cheers,

Wendell

Highlighted

Re: Ambari Blueprint doesn't configure the SmartSense ActiveAnalysis Admin password

New Contributor

In case of Blueprint install you need to add the below property to configuration list, to set this password for SmartSense:

"activity-zeppelin-shiro": {
    "properties": {
       "users.admin": "YOUR_SECRET_ADMIN_PASSWORD"
    }
}
Highlighted

Re: Ambari Blueprint doesn't configure the SmartSense ActiveAnalysis Admin password

Rising Star

Hi @wbu,

@Alejandro Fernandez's and

@smagyari's

are both correct.

The main problem is that SmartSense's Ambari Stack definitions are not included in the default stack definitions. Generally, the configuration properties that are passwords are marked with metadata to indicate that a given property is of type "PASSWORD". This metadata is used by the Blueprints processor in order to determine which properties can be set with the value of "default_password", which is set in the Cluster Creation Template.

In the current release (Ambari 2.4), the only way to resolve this would be to use @smagyari's recommendation, and set the password directly. Generally, we recommend that passwords only be included in the Cluster Creation Template, since Ambari does not persist that document.

Hope this helps!

Highlighted

Re: Ambari Blueprint doesn't configure the SmartSense ActiveAnalysis Admin password

Contributor

Hi

@rnettleton and @Attila Kanto and @smagyari

Your solution is fine for manually provision the cluster with blueprint. But within current version cloudbreak, there's no way to add a template. You can only either inherit "default_password" configured in cloudbreak UI or add "users.admin" in your blueprint which is less secured.

Regards,

Wendell

Highlighted

Re: Ambari Blueprint doesn't configure the SmartSense ActiveAnalysis Admin password

Contributor

Hi @smagyari

I did try to add users.admin in the blueprint. The password still needs to be manually added on the UI.

    {
      "hst-server-conf": {
        "properties": {
          "customer.account.name": "Hortonworks PS EMEA",
          "agent.request.processing.timeout": "7200",
          "client.threadpool.size.max": "40",
          "server.storage.dir": "/var/lib/smartsense/hst-server/data",
          "gateway.registration.port": "9450",
          "gateway.port": "9451",
          "customer.notification.email": "ps_test@hortonworks.com",
          "agent.request.syncup.interval": "180",
          "gateway.host": "embedded",
          "server.port": "9000",
          "server.tmp.dir": "/var/lib/smartsense/hst-server/tmp",
          "customer.smartsense.id": "A-88888888-C-88888888",
          "users.admin": "admin"
        }
      }
    },

Can you please double check whether there's a bug in Ambari?

Regards,

Wendell

Highlighted

Re: Ambari Blueprint doesn't configure the SmartSense ActiveAnalysis Admin password

New Contributor

Hi @wbu

Right the problem here is that 'users.admin' property must be set on 'activity-zeppelin-shiro' config type not on 'hst-server-conf'. I've tried it and seems to work fine.

BR

Sandor

Don't have an account?
Coming from Hortonworks? Activate your account here