Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

Ambari Dashboard not working

New Contributor

Hi All,

I am a noob w.r.t Hadoop.

I started with the Hortonworks HDP a week earlier. I am using Oracle VirtualBox 5.2.14 and Hortonworks Sandbox HDP 2.6.5.

I started Ambari using http://localhost:1080 and launching the Dashboard. It worked fine the first day and I even created a few tables in Hive. I POWERED OFF my VirtualBox that day.

Since the next day when I am trying to access the dashboard, it first throws the below error.

502 Bad Gateway nginx/1.15.0

Then after a few tries, it opens the Ambari Dashboard. This happens every time.

But then there are errors on the main page. Screenshot Ambari_Main.

I have tried to STOP ALL and then START ALL the services. But it throws the error during the App Timeline Server Start service.


Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/common-services/YARN/", line 89, in <module>
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/", line 375, in execute
  File "/var/lib/ambari-agent/cache/common-services/YARN/", line 43, in start
    self.configure(env) # FOR SECURITY
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/", line 120, in locking_configure
    original_configure(obj, *args, **kw)
  File "/var/lib/ambari-agent/cache/common-services/YARN/", line 54, in configure
  File "/usr/lib/ambari-agent/lib/ambari_commons/", line 89, in thunk
    return fn(*args, **kwargs)
  File "/var/lib/ambari-agent/cache/common-services/YARN/", line 359, in yarn
  File "/usr/lib/ambari-agent/lib/resource_management/core/", line 166, in __init__
  File "/usr/lib/ambari-agent/lib/resource_management/core/", line 160, in run
    self.run_action(resource, action)
  File "/usr/lib/ambari-agent/lib/resource_management/core/", line 124, in run_action
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/providers/", line 606, in action_create_on_execute
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/providers/", line 603, in action_delayed
    self.get_hdfs_resource_executor().action_delayed(action_name, self)
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/providers/", line 330, in action_delayed
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/providers/", line 289, in _assert_valid
    self.target_status = self._get_file_status(target)
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/providers/", line 432, in _get_file_status
    list_status = self.util.run_command(target, 'GETFILESTATUS', method='GET', ignore_status_codes=['404'], assertable_result=False)
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/providers/", line 177, in run_command
    return self._run_command(*args, **kwargs)
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/providers/", line 237, in _run_command
    _, out, err = get_user_call_output(cmd, user=self.run_user, logoutput=self.logoutput, quiet=False)
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/functions/", line 61, in get_user_call_output
    raise ExecutionFailed(err_msg, code, files_output[0], files_output[1])
resource_management.core.exceptions.ExecutionFailed: Execution of 'curl -sS -L -w '%{http_code}' -X GET '' 1>/tmp/tmpRDJltk 2>/tmp/tmpK9kAhT' returned 7. curl: (7) Failed connect to; Connection refused



Please let me know a fix to the issue. I am stuck here for the past one week.

Thanks in advance,




@Manob Chakraborty

From your screenshot, the following components are in maintenance mode HDFS, Hive, HBase, Falcon etc the App Timeline server need to connect to the NameNode which is the Master process of HDFS.

So I suggest you turn off maintenance mode for HDFS and any other component like hive and hbase and restart the stale service and retry.

It should start normally.

Please revert

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.