Support Questions
Find answers, ask questions, and share your expertise

Ambari - Operating System matching redhat7 could not be found

Explorer

After upgrading from Ambari 2.5.0.3 to 2.6.2.2, ambari-server.log file suddenly start recording following entries:

 

28 Nov 2020 16:48:52,372  WARN [ambari-action-scheduler] ActionScheduler:316 - Exception received
java.lang.RuntimeException: org.apache.ambari.server.controller.spi.SystemException: Operating System matching redhat7 could not be found
        at org.apache.ambari.server.actionmanager.ExecutionCommandWrapper.getExecutionCommand(ExecutionCommandWrapper.java:253)
        at org.apache.ambari.server.actionmanager.ActionScheduler.processInProgressStage(ActionScheduler.java:704)
        at org.apache.ambari.server.actionmanager.ActionScheduler.doWork(ActionScheduler.java:417)
        at org.apache.ambari.server.actionmanager.ActionScheduler.run(ActionScheduler.java:310)
        at java.lang.Thread.run(Thread.java:748)
Caused by: org.apache.ambari.server.controller.spi.SystemException: Operating System matching redhat7 could not be found
        at org.apache.ambari.server.state.stack.upgrade.RepositoryVersionHelper.getOSEntityForHost(RepositoryVersionHelper.java:422)
        at org.apache.ambari.server.actionmanager.ExecutionCommandWrapper.getExecutionCommand(ExecutionCommandWrapper.java:247)
        ... 4 more

 

 

Server's OS has always been RedHat 7.x and prior to the upgrade there were no issues with the OS version:

 

 

$ cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.5 (Maipo)

 

 

To make this more interesting, Ambari WebUI in the hosts details correctly identifies the OS version

 

 

OS: redhat7 (x86_64)

 

 

Ambari WebUI and `ambari-server --version` already show upgraded version `2.6.2.2`.

 

Please help solve this issue.

1 ACCEPTED SOLUTION

Accepted Solutions

@GregDol Please follow the below documentation and ensure to update the repository to use RedHat Satellite to fix the issue. https://docs.cloudera.com/HDPDocuments/Ambari-2.6.1.0/bk_ambari-installation/content/using_a_local_r...


Cheers!
Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

View solution in original post

4 REPLIES 4

@GregDol Please follow the below documentation and ensure to update the repository to use RedHat Satellite to fix the issue. https://docs.cloudera.com/HDPDocuments/Ambari-2.6.1.0/bk_ambari-installation/content/using_a_local_r...


Cheers!
Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

View solution in original post

Explorer

@GangWar Would it be safe to check the "Skip Repository Base URL validation" and uncheck the "Use Redhat Satellite/Spacewalk" options?

Yes, that's fine. 


Cheers!
Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Explorer

@GangWar Everything went smoothly after your reply.  Thank you.