Support Questions
Find answers, ask questions, and share your expertise

Ambari-server Setup Issue

Explorer

Hi

I am trying to setup ambari on a virtual machine and run into below issue. I researched with the error and tried all the inputs but no luck.

# yum repolist

Loaded plugins: product-id, search-disabled-repos, security, subscription-manager

ambari | 2.9 kB 00:00

repo id repo name status

HDP HDP Version - HDP-2.3.4.0 175

HDP-UTILS HDP Utils Version - HDP-UTILS-1.1.0.20 43

ambari ambari-2.5.0.3 12

# yum install ambari-server

Loaded plugins: product-id, search-disabled-repos, security, subscription-manager Setting up Install Process Package ambari-server-2.5.0.3-7.x86_64 already installed and latest version Nothing to do

# ambari-server setup

Using python /usr/bin/python

Setup ambari-server

Traceback (most recent call last):

File "/usr/sbin/ambari-server.py", line 40, in <module>

from ambari_server.serverUpgrade import upgrade, upgrade_stack, set_current

File "/usr/lib/python2.6/site-packages/ambari_server/serverUpgrade.py", line 51, in <module>

from ambari_server.setupMpacks import replay_mpack_logs

File "/usr/lib/python2.6/site-packages/ambari_server/setupMpacks.py", line 42, in <module>

from resource_management.libraries.functions.tar_archive import extract_archive, get_archive_root_dir

ImportError: cannot import name extract_archive

Any help is greatly appreciated.

Thanks,

Abhishek

18 REPLIES 18

Mentor

@Abhishek Reddy Chamakura

The installation was successful at the end, so there should be something definitely wrong with either your OS or packages

Enjoy!!!


10-review.jpg11-install-start-test.jpg

Mentor

@Abhishek Reddy Chamakura

Confirmation of service and versions


12-versions.jpg13-all-green.jpg

Explorer

Hi Geoffrey,

Thank you very much for taking time and testing the installation. I have gone through all of your screenshots. This is what I am planning to do but I am running into issues at the very beginning of the installation of Ambari Server. I will further research into the issue I am running into. Will update you if I find anything.

Thank you very much for your time and fast response.

Have a great weekend!

Thanks

Mentor

@Abhishek Reddy Chamakura

Can you share the document you are using this cluster install, maybe I could see something that you aint't seeing 🙂 Are you using a satellite server for repos? Can you share the contents of your ambari,hdp and hdp-utils.repos??

I usually don't like to leave an issue un resolved!!

Explorer

Hi Geoffrey,

Sorry for my late response. I got busy over the weekend and totally forgot to respond back with details. I will gather all the details and message you. Thank you for your support.

Thanks

Explorer

Hi Geoffrey,

Let me give you a little overview on how and where it all started.

Since we have only one Hadoop Cluster which started as a POC and later it was converted to Production environment , we didn't have a lower environment similar to production for testing. So I planned to standup a production like environment with 10 nodes.

I requested for 10 new virtual machines with RHEL 6.9 from devops team at our organization. They provided me 10 new vm's.Brand new vm's with no applications running on it. The devops team did one additional step on the new vm's - enabled chef on the new vm's. Upon the chef-client run it downloaded the below HDP repos , I didn't download the HDP repos neither I used them. I only downloaded ambari repo using the below links

repo id repo name

HDP HDP Version - HDP-2.3.4.0

HDP-UTILS HDP Utils Version - HDP-UTILS-1.1.0.20

Ambari-2.5.0.3 Repo Download Link wget -nv http://public-repo-1.hortonworks.com/ambari/centos6/2.x/updates/2.5.0.3/ambari.repo -O /etc/yum.repos.d/ambari.repo

I can stop the chef-client on the new vm's and remove the HDP repos. I want to setup a cluster with Ambari - 2.5.0.3 in the lab environment because currently we are running Ambari - 2.5.0.3 in production. We are planning to upgrade the Ambari version in production. Since I don't have a environment to test the upgrade , I wanted to setup the lab environment with the similar Ambari version in production and ran into ambari-setup issues.

The VM's doesn't have any HDP packages installed or distributed. The VM's are all new and having nothing related to HDP.

Please let me know if you need any further information or a webx session to look into it further.

Thanks

Mentor

Explorer

Hi Geoffrey,

Some additional info on the node on which I was trying to setup ambari

$ sudo yum list installed | grep -i ambari

ambari-agent.x86_64 2.1.2.1-418 @ambari

ambari-server.x86_64 2.5.0.3-7 @ambari

$ sudo yum list installed | grep -i hdp

hdparm.x86_64 9.43-4.el6 @RHEL6-Server-DVD

libgenders.x86_64 1.14-2.el6.rf @HDP-UTILS

pdsh.x86_64 2.27-1.el6.rf @HDP-UTILS

Thanks,
Abhishek

Explorer

Resolution Found - Please follow below steps

1. Install Ambari Agent

2. Check the status of ambari agent - Start it if not up

3. Try yum install ambari-server

Thank you all for all the help.

Thanks,
Abhishek