Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
10-24-2021
01:12 PM
- last edited on
04-21-2026
01:55 AM
by
GrazittiAPI
Hi everyone,
I have installed CDP 7.1.6 cluster, with kerberos and TLS enabled.
All services works fine except Atlas I get the error:
HTTP ERROR 503 Service Unavailable
URI: /
STATUS: 503
MESSAGE: Service Unavailable
Needed kafka topics, hbase tables and Solr collections all are created, needed policies on Ranger too are good
I cannot neither enable the service Atlas for HBase
I don't have any Error on atlas application.log :
Any idea ?
2021-10-24 21:03:45,634 INFO - [main:] ~ Attempting to retrieve password for key password from cert.stores.credential.provider.path configured credential provider path localjceks://file//var/run/cloudera-scm-agent/process/1546354754-atlas-ATLAS_SERVER/conf/atlascreds.localjceks (SecurityUtil:63)
2021-10-24 21:03:45,638 DEBUG - [main:] ~ backing jks path initialized to file:/var/run/cloudera-scm-agent/process/1546354754-atlas-ATLAS_SERVER/conf/atlascreds.localjceks (AbstractJavaKeyStoreProvider:169)
2021-10-24 21:03:45,638 DEBUG - [main:] ~ initialized local file as '/var/run/cloudera-scm-agent/process/1546354754-atlas-ATLAS_SERVER/conf/atlascreds.localjceks'. (LocalKeyStoreProvider:123)
2021-10-24 21:03:45,639 DEBUG - [main:] ~ the local file exists and is size 1481 (LocalKeyStoreProvider:125)
2021-10-24 21:03:45,639 TRACE - [main:] ~ we can read the local file. (LocalKeyStoreProvider:128)
2021-10-24 21:03:45,639 TRACE - [main:] ~ we can write the local file. (LocalKeyStoreProvider:131)
2021-10-24 21:03:45,740 INFO - [main:] ~ Attempting to retrieve password for key truststore.password from cert.stores.credential.provider.path configured credential provider path localjceks://file//var/run/cloudera-scm-agent/process/1546354754-atlas-ATLAS_SERVER/conf/atlascreds.localjceks (SecurityUtil:63)
2021-10-24 21:03:45,745 DEBUG - [main:] ~ backing jks path initialized to file:/var/run/cloudera-scm-agent/process/1546354754-atlas-ATLAS_SERVER/conf/atlascreds.localjceks (AbstractJavaKeyStoreProvider:169)
2021-10-24 21:03:45,746 DEBUG - [main:] ~ initialized local file as '/var/run/cloudera-scm-agent/process/1546354754-atlas-ATLAS_SERVER/conf/atlascreds.localjceks'. (LocalKeyStoreProvider:123)
2021-10-24 21:03:45,746 DEBUG - [main:] ~ the local file exists and is size 1481 (LocalKeyStoreProvider:125)
2021-10-24 21:03:45,746 TRACE - [main:] ~ we can read the local file. (LocalKeyStoreProvider:128)
2021-10-24 21:03:45,746 TRACE - [main:] ~ we can write the local file. (LocalKeyStoreProvider:131)
2021-10-24 21:05:53,494 DEBUG - [main:] ~ <== AtlasErrorCode.getMessage([]) (AtlasErrorCode:247)
2021-10-24 21:05:53,494 DEBUG - [main:] ~ ==> AtlasErrorCode.getMessage([]): EmbeddedServer.Start: failed! (AtlasErrorCode:254)
Created 11-09-2021 12:21 PM
I finally managed to resolve this problem with the help of the cloudera support
---------- WARN - [main:]
~ Failed startup of context o.e.j.w.WebAppContext@6c5945a7{/,file:///opt/cloudera/parcels/CDH-7.1.6-1.cdh7.1.6.p0.10506313/lib/atlas/server/webapp/atlas/,UNAVAILABLE}
{/opt/cloudera/parcels/CDH-7.1.6-1.cdh7.1.6.p0.10506313/lib/atlas/server/webapp/atlas}
(WebAppContext:533) java.net.ConnectException: Connexion terminée par expiration du délai d'attente (Connection timed out)
it seems to be a known issue :
So the solution is :
in each Atlas host
20 <!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
21 http://java.sun.com/dtd/web-app_2_3.dtd>
- Restart ATLAS
Created 11-09-2021 12:21 PM
I finally managed to resolve this problem with the help of the cloudera support
---------- WARN - [main:]
~ Failed startup of context o.e.j.w.WebAppContext@6c5945a7{/,file:///opt/cloudera/parcels/CDH-7.1.6-1.cdh7.1.6.p0.10506313/lib/atlas/server/webapp/atlas/,UNAVAILABLE}
{/opt/cloudera/parcels/CDH-7.1.6-1.cdh7.1.6.p0.10506313/lib/atlas/server/webapp/atlas}
(WebAppContext:533) java.net.ConnectException: Connexion terminée par expiration du délai d'attente (Connection timed out)
it seems to be a known issue :
So the solution is :
in each Atlas host
20 <!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
21 http://java.sun.com/dtd/web-app_2_3.dtd>
- Restart ATLAS