Support Questions
Find answers, ask questions, and share your expertise

Apache Metron Mpack installation fails for single node

Apache Metron Mpack installation fails for single node

Explorer

metron-mpack-0710.tar.gz .

I am using Ubuntu 14 ,HDP -2.6.5.0-292,Ambari 2.7.3 version using https://github.com/apache/metron/tree/master/metron-deployment/packaging/ambari/metron-mpack. I skipped step 6 as I am using only one node and I am getting the below error. Can someone help to fix this error.

Traceback (most recent call last):

File "/var/lib/ambari-server/resources/scripts/stack_advisor.py", line 190, i$

main(sys.argv)

File "/var/lib/ambari-server/resources/scripts/stack_advisor.py", line 122, i$

result = stackAdvisor.validateComponentLayout(services, hosts)

File "/var/lib/ambari-server/resources/scripts/../stacks/stack_advisor.py", l$

validationItems = self.getComponentLayoutValidations(services, hosts)

File "/var/lib/ambari-server/resources/scripts/../stacks/HDP/2.5/services/sta$

parentItems = super(HDP25StackAdvisor, self).getComponentLayoutValidations($

File "/var/lib/ambari-server/resources/scripts/../stacks/HDP/2.0.6/services/s$

items = super(HDP206StackAdvisor, self).getComponentLayoutValidations(servi$

File "/var/lib/ambari-server/resources/scripts/../stacks/stack_advisor.py", l$

items.extend(serviceAdvisor.getServiceComponentLayoutValidations(services, $

File "/var/lib/ambari-server/resources/common-services/METRON/0.7.1/service_a$

metronParsersHost = self.getHosts(componentsList, "METRON_PARSERS")[0]

IndexError: list index out of range
6 REPLIES 6

Re: Apache Metron Mpack installation fails for single node

Super Collaborator

It looks like you are trying this with HDP 3.x -- which is not supported as yet by HCP. Can you try with HDP 2.6.5.0 ?

Re: Apache Metron Mpack installation fails for single node

Explorer

i used HDP -2.6.5.0-292 only . Somehow the hostname was not able to get .Fixed the issue by hardcoding the hostname

Re: Apache Metron Mpack installation fails for single node

Explorer

I am using HDP 2.6.5 only

Re: Apache Metron Mpack installation fails for single node

Explorer

@asubramanian I am using HDP 2.6.5.0.292 only. I fixed the above issue and when I was about to install datanode and other components with three nodes set up ,I am getting the below error

stderr: 
Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/stack-hooks/before-ANY/scripts/hook.py", line 38, in 
    BeforeAnyHook().execute()
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", line 352, in execute
    method(env)
  File "/var/lib/ambari-agent/cache/stack-hooks/before-ANY/scripts/hook.py", line 31, in hook
    setup_users()
  File "/var/lib/ambari-agent/cache/stack-hooks/before-ANY/scripts/shared_initialization.py", line 50, in setup_users
    groups = params.user_to_groups_dict[user],
KeyError: u'metron'
Error: Error: Unable to run the custom hook script ['/usr/bin/python', '/var/lib/ambari-agent/cache/stack-hooks/before-ANY/scripts/hook.py', 'ANY', '/var/lib/ambari-agent/data/command-1001.json', '/var/lib/ambari-agent/cache/stack-hooks/before-ANY', '/var/lib/ambari-agent/data/structured-out-1001.json', 'INFO', '/var/lib/ambari-agent/tmp', 'PROTOCOL_TLSv1', '']2019-01-28 20:59:11,683 - Reporting component version failed
Traceback (most recent call last):
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", line 363, in execute
    self.save_component_version_to_structured_out(self.command_name)
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", line 223, in save_component_version_to_structured_out
    stack_select_package_name = stack_select.get_package_name()
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/functions/stack_select.py", line 109, in get_package_name
    package = get_packages(PACKAGE_SCOPE_STACK_SELECT, service_name, component_name)
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/functions/stack_select.py", line 223, in get_packages
    supported_packages = get_supported_packages()
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/functions/stack_select.py", line 147, in get_supported_packages
    raise Fail("Unable to query for supported packages using {0}".format(stack_selector_path))
Fail: Unable to query for supported packages using /usr/bin/hdp-select
 stdout:
2019-01-28 20:59:11,645 - Stack Feature Version Info: Cluster Stack=2.6, Command Stack=None, Command Version=None -> 2.6
2019-01-28 20:59:11,649 - Using hadoop conf dir: /usr/hdp/current/hadoop-client/conf
2019-01-28 20:59:11,651 - Group['metron'] {}
2019-01-28 20:59:11,651 - Group['hdfs'] {}
2019-01-28 20:59:11,651 - Group['zeppelin'] {}
2019-01-28 20:59:11,652 - Group['hadoop'] {}
2019-01-28 20:59:11,652 - Group['users'] {}
Error: Error: Unable to run the custom hook script ['/usr/bin/python', '/var/lib/ambari-agent/cache/stack-hooks/before-ANY/scripts/hook.py', 'ANY', '/var/lib/ambari-agent/data/command-1001.json', '/var/lib/ambari-agent/cache/stack-hooks/before-ANY', '/var/lib/ambari-agent/data/structured-out-1001.json', 'INFO', '/var/lib/ambari-agent/tmp', 'PROTOCOL_TLSv1', '']
2019-01-28 20:59:11,683 - Reporting component version failed
Traceback (most recent call last):
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", line 363, in execute
    self.save_component_version_to_structured_out(self.command_name)
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", line 223, in save_component_version_to_structured_out
    stack_select_package_name = stack_select.get_package_name()
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/functions/stack_select.py", line 109, in get_package_name
    package = get_packages(PACKAGE_SCOPE_STACK_SELECT, service_name, component_name)
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/functions/stack_select.py", line 223, in get_packages
    supported_packages = get_supported_packages()
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/functions/stack_select.py", line 147, in get_supported_packages
    raise Fail("Unable to query for supported packages using {0}".format(stack_selector_path))
Fail: Unable to query for supported packages using /usr/bin/hdp-select

Re: Apache Metron Mpack installation fails for single node

Super Collaborator

Hi @Hemamalini Nithyanandam , can you tell me the steps that fixed the problem for you?

Re: Apache Metron Mpack installation fails for single node

Explorer

Hi @asubramanian i hard coded the host in var/lib/ambari-server/resources/common-services/METRON/0.7.1/service

metronParsersHost = "hostname"