Support Questions
Find answers, ask questions, and share your expertise

Apache Metron dev install error

Solved Go to solution

Apache Metron dev install error

TASK [ambari_config : Install python-requests] *********************************

ok: [node1]

TASK [ambari_config : check if ambari-server is up on node1:8080] **************

ok: [node1]

TASK [ambari_config : Deploy cluster with Ambari; http://node1:8080] ***********

fatal: [node1]: FAILED! => {"changed": false, "failed": true, "msg": "value of wait_for_complete must be one of: yes,on,1,true,1,True,no,off,0,false,0,False, got: True"}

NO MORE HOSTS LEFT *************************************************************

to retry, use: --limit @../../playbooks/metron_full_install.retry

PLAY RECAP *********************************************************************

node1 : ok=36changed=5 unreachable=0 failed=1

Ansible failed to complete successfully. Any error output should be

visible above. Please fix these errors and try again.

I am following https://github.com/apache/incubator-metron/tree/master/metron-deployment/vagrant/full-dev-platform and hitting the above while provisioning.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Apache Metron dev install error

Explorer

@Neeraj Sabharwal

Hi Neeraj,

Could you please check ansible version you are running the code with?(ansible --version)

For metron deployment, ansible 2.0.0.2 is required.

Note :- If you perform a "pip install ansible"...It installs ansible-2.1.0.0 and we happen to come across the issue you mentioned.

Incase you have a different version of ansible installed than 2.0.0.2,please perform the following steps and rerun the metron deployment :-

pip uninstall ansible

pip install ansible==2.0.0.2

Regards,

Neha

View solution in original post

5 REPLIES 5

Re: Apache Metron dev install error

Re: Apache Metron dev install error

Explorer

@Neeraj Sabharwal

Hi Neeraj,

Could you please check ansible version you are running the code with?(ansible --version)

For metron deployment, ansible 2.0.0.2 is required.

Note :- If you perform a "pip install ansible"...It installs ansible-2.1.0.0 and we happen to come across the issue you mentioned.

Incase you have a different version of ansible installed than 2.0.0.2,please perform the following steps and rerun the metron deployment :-

pip uninstall ansible

pip install ansible==2.0.0.2

Regards,

Neha

View solution in original post

Re: Apache Metron dev install error

@Neha Sinha I did follow that..getting this

==> node1: Updating /etc/hosts file on host machine (password may be required)...

==> node1: Running provisioner: ansible...

node1: Running ansible-playbook...

Unexpected Exception: (setuptools 1.1.6 (/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python), Requirement.parse('setuptools>=11.3'))

the full traceback was:

Traceback (most recent call last):

File "/usr/local/bin/ansible-playbook", line 72, in <module>

mycli = getattr(__import__("ansible.cli.%s" % sub, fromlist=[myclass]), myclass)

File "/Library/Python/2.7/site-packages/ansible/cli/playbook.py", line 30, in <module>

from ansible.executor.playbook_executor import PlaybookExecutor

File "/Library/Python/2.7/site-packages/ansible/executor/playbook_executor.py", line 30, in <module>

from ansible.executor.task_queue_manager import TaskQueueManager

File "/Library/Python/2.7/site-packages/ansible/executor/task_queue_manager.py", line 29, in <module>

from ansible.executor.play_iterator import PlayIterator

File "/Library/Python/2.7/site-packages/ansible/executor/play_iterator.py", line 29, in <module>

from ansible.playbook.block import Block

File "/Library/Python/2.7/site-pa

Re: Apache Metron dev install error

@Neha Sinha I executed this pip install --upgrade setuptools --user python to fix the above error

TASK [ambari_config : check if ambari-server is up on node1:8080] **************

fatal: [node1]: FAILED! => {"changed": false, "elapsed": 300, "failed": true, "msg": "Timeout when waiting for node1:8080"}

PLAY RECAP *********************************************************************

node1 : ok=11changed=5 unreachable=0 failed=1

Ansible failed to complete successfully. Any error output should be

visible above. Please fix these errors and try again.

Re: Apache Metron dev install error

Explorer

@Neeraj Sabharwal

Hi Neeraj,

Kindly upgrade your setuptools to a version >=11.3.

In my environment I am running ansible 2.0.0.2 with setuptools (24.0.0).

Regards,

Neha