Support Questions

Find answers, ask questions, and share your expertise

Apache Ranger policies are not not working at all. Please do the needful

New Contributor

Created a policy for Hive. Checked all the configuration settings, still its not working..

6 REPLIES 6

New Contributor

What's the query you're trying to run? Also, please provide a snapshot of the list of all policies

New Contributor

Able to create policies for HDFS and results are as expected. Still have issues with HIve policies. Also, policy tags are not in sync with Apache Atlas and Ranger .. Can any one help ? Already attached the policy created for Hive, I only gave select permission on employee table. But I can still insert the data into the table. Here is the query I am trying to run - insert into employee values (21,'Sasi',25,20000,'Bangalore');

Please provide more details on your scenario and environment. Do you see any errors in hive server2 and ranger logs?

New Contributor

Able to create policies for HDFS and results are as expected. Still have issues with HIve policies. Also, policy tags are not in sync with Apache Atlas and Ranger .. Can any one help ? Already attached the policy created for Hive, I only gave select permission on employee table. But I can still insert the data into the table. Here is the query I am trying to run - insert into employee values (21,'Sasi',25,20000,'Bangalore');

New Contributor

Also, tag based policy created in Ranger is stored in mysql ranger database. But not reflected in Atlas.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.