Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Apache nifi Distributed map cache client service giving error

avatar
New Contributor

I am using the utility of wait and notify and for that I have used Distributed map cache client service and Distributed map cache server, but somehow I am getting an error in service "too many open files", I have even increased the "nofile" in node. In the same instance but in another nifi flow I am able to use this functionality but if I do configure this service in another parallel flow I face issues. Below I am attaching the screenshot of conf and error. any help would be appreciated.

Screenshot 2022-05-25 at 1.46.27 PM.pngScreenshot 2022-05-25 at 1.49.42 PM.pngScreenshot 2022-05-25 at 1.50.03 PM.png

1 REPLY 1

avatar
Master Mentor

@Mridul_garg 
Sharing the complete stack trace(s) from the nifi-app.log maybe be helpful in helping you here.
When you say you changed the open file limits, what ddi you change it to?
what does the output from "ulimit -a" show.  Make sure you run this command as the same user that owns your NiFi process.

Thanks,
Matt