Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Atlas Installation Error!

Atlas Installation Error!

Explorer

Hi,

I am installing Atlas service on Ambari and getting below error . I have installed solr on ambari and using it for Atlas service.

Error -

Caused by: org.apache.solr.client.solrj.impl.HttpSolrClient$RemoteSolrException: Error from server at http://xxxx:8983/solr: Can not find the specified config set: vertex_index

Environment -

Ambari version - 2.6.0

HDP - 2.6.3

Kerberised - Yes

Atlas configuration -

atlas.graph.index.search.solr.zookeeper-url = ZOOKEEPER_HOSTNAME:2181/solr

atlas.audit.hbase.zookeeper.quorum = ZOOKEEPER_HOSTNAME

Could you please help me out to fix this issue? Do i need to manually create "vertex_index" on solr instance?

Thanks,

Kumar TG

2 REPLIES 2

Re: Atlas Installation Error!

Mentor

@Kumar Tg

I have the same setup on a single node cluster, I think your atlas.graph.index.search.solr.zookeeper-url should be changed to infra-solr. I logged in my zookeeper to check the parameters. The vertex_index is accessible in infra-solr

$ bin/zkCli.sh
.....
[zk: localhost:2181(CONNECTED) 0] ls /
[hive, registry, cluster, controller, brokers, zookeeper, infra-solr, hbase-unsecure, kafka-acl, kafka-acl-changes, admin, isr_change_notification, templeton-hadoop, hiveserver2, controller_epoch, druid, rmstore, hbase-secure, ambari-metrics-cluster, consumers, config]
[zk: localhost:2181(CONNECTED) 2] ls /infra-solr/collections
[vertex_index, edge_index, fulltext_index] 

Parameter to change

atlas.graph.index.search.solr.zookeeper-url = ZOOKEEPER_HOSTNAME:2181/infra-solr 

Then try restarting Atlas. Please let me know

Re: Atlas Installation Error!

Explorer

Hi @Geoffrey Shelton Okot,

Thanks for your reply.

I am using "Solr" service not "Infra-solr" cloud service. So the vaule provided for "atlas.graph.index.search.solr.zookeeper-url" parameter indeed correct.("ZOOKEEPER_HOSTNAME:2181/solr")

To fix this issue, i have manually created two Solr collections - vertex_index , fulltext_index and restarted Atlas service. Its working fine now.

Solr Collections -

$ solr create -c vertex_index -shards 1 -replicationFactor 1

$ solr create -c fulltext_index -shards 1 -replicationFactor 1

Question - Why Solr collections are not created while installing Atlas service? Does it supports only "Infra-Solr" ?

Thanks,

Kumar TG