Support Questions
Find answers, ask questions, and share your expertise

Atlas build fails

Solved Go to solution

Atlas build fails

Explorer

I'm trying to build Atlas from source: https://github.com/hortonworks/atlas-release/tree/HDP-3.0.1.0-187-tag

When executing

mvn clean install

the build fails with

[ERROR] Failed to execute goal on project atlas-testtools: Could not resolve dependencies for project org.apache.atlas:atlas-testtools:jar:1.0.0.3.0.0.0-SNAPSHOT: The following artifacts could not be resolved: org.apache.hadoop:hadoop-annotations:jar:3.0.0.3.0.0.0-SNAPSHOT, org.apache.hadoop:hadoop-auth:jar:3.0.0.3.0.0.0-SNAPSHOT, org.apache.hadoop:hadoop-common:jar:3.0.0.3.0.0.0-SNAPSHOT, org.apache.hadoop:hadoop-hdfs:jar:3.0.0.3.0.0.0-SNAPSHOT, org.apache.zookeeper:zookeeper:jar:3.4.6.3.0.0.0-SNAPSHOT: Could not find artifact org.apache.hadoop:hadoop-annotations:jar:3.0.0.3.0.0.0-SNAPSHOT in apache.snapshots.repo (https://repository.apache.org/content/groups/snapshots) -> [Help 1]

How can I make it resolve these dependencies?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Atlas build fails

@Maxim Neaga

Do add the below hortonworks nexus repo to your ${user.home}/.m2/settings.xml file.

  <profile>
     <id>Hortonworks</id>
     <repositories>
       <repository>
         <id>hortonworks-nexus</id>
         <name>nexus repo</name>
         <url>http://nexus-private.hortonworks.com/nexus/content/groups/public/</url>
       </repository>
     </repositories>
   </profile>

and build using

mvn clean -DskipTests package -Pdist -PHortonworks

View solution in original post

2 REPLIES 2

Re: Atlas build fails

@Maxim Neaga

Do add the below hortonworks nexus repo to your ${user.home}/.m2/settings.xml file.

  <profile>
     <id>Hortonworks</id>
     <repositories>
       <repository>
         <id>hortonworks-nexus</id>
         <name>nexus repo</name>
         <url>http://nexus-private.hortonworks.com/nexus/content/groups/public/</url>
       </repository>
     </repositories>
   </profile>

and build using

mvn clean -DskipTests package -Pdist -PHortonworks

View solution in original post

Re: Atlas build fails

Explorer

Thank you, that did it! Is this documented anywhere?