Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

Atlas import is failing : HDP to CDP

Expert Contributor

Hi All,


We are in process of migrating HDP cluster to CDP. As we would like to retain Atlas lineage in CDP from HDP, we have exported them from HDP cluster which gave us a .zip file. Extracted it and remediated the contents of .json files to match the CDP cluster name and server names, then zipped it back to a file.


Now when running Atlas import API command to import remediated Atlas data to CDP Atlas, we are getting below error for most of the Atlas imports. 

{"errorCode":"ATLAS-404-00-007","errorMessage":"Invalid instance creation/updation parameters passed : type_name.entity_name: mandatory attribute value missing in type type_name"}


Also, have some more errors, which certainly need to be looked into but not super priority.

{"errorCode":"ATLAS-400-00-08A","errorMessage":"Attempting to import empty ZIP file."}:



Having tried to figure this out since a week, but still no luck.


Any suggestions / guidance will be really helpful.