Support Questions
Find answers, ask questions, and share your expertise

Atlas not accessible due to "atlas_titan" permissions

Solved Go to solution

Atlas not accessible due to "atlas_titan" permissions

I have a docker HDP 2.5 installed on Azure. Atlas was working fine but after running for a while it became inaccessible. Looking at the logs I see the below HBase permission error:

... 38 more
Caused by: org.apache.hadoop.hbase.security.AccessDeniedException: org.apache.hadoop.hbase.security.AccessDeniedException: Insufficient permissions (user=atlas, scope=default, params=[namespace=default,table=default:atlas_titan,family=s],action=CREATE)

  at org.apache.hadoop.hbase.security.access.AccessController.requireNamespacePermission(AccessController.java:624)

  at ...

However, in Ranger UI the correct permissions seem to be in place; user "atlas" has full permissions to HBase table "atlas_titan".

Any thoughts, or pointers on this?

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Atlas not accessible due to "atlas_titan" permissions

Explorer

This : Insufficient permissions (user=atlas, scope=default,params=[namespace=default,table=default:atlas_titan,family=s],action=CREATE

Simply means that your Atlas service user has no longer access to the backend tables , therefore the Atlas Rest API service can't serve the records which in turn causes the empty http response .

First , stop the Atlas service in Ambari Admin Ui, then connect in the container as a root follow these steps:

# su hbase hbase shell

  • Execute the following command in HBase shell, to grant global permissions to 'atlas' user so it can create the tables it needs:

hbase(main):001:0> grant 'atlas', 'RWXCA'

  • Start Atlas service in Ambari Admin Ui, Execute the following command in HBase shell, to revoke global permissions granted to 'atlas' user:

hbase(main):001:0> revoke 'atlas'

  • Execute the following commands in HBase shell, to enable Atlas to access necessary HBase tables

hbase(main):001:0> grant 'atlas', 'RWXCA', 'atlas_titan'

hbase(main):001:0> grant 'atlas', 'RWXCA', 'ATLAS_ENTITY_AUDIT_EVENTS'

hbase(main):001:0> exit

Return to the Ambari Admin UI , start the Altas service

You should be able to check by connecting back to Atlas dashboard , or simple watch the log

tail -f /var/log/atlas/application.log

For details please refer to the following : http://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.5.0/bk_data-governance/content/ch_hdp_data_gove...

View solution in original post

1 REPLY 1

Re: Atlas not accessible due to "atlas_titan" permissions

Explorer

This : Insufficient permissions (user=atlas, scope=default,params=[namespace=default,table=default:atlas_titan,family=s],action=CREATE

Simply means that your Atlas service user has no longer access to the backend tables , therefore the Atlas Rest API service can't serve the records which in turn causes the empty http response .

First , stop the Atlas service in Ambari Admin Ui, then connect in the container as a root follow these steps:

# su hbase hbase shell

  • Execute the following command in HBase shell, to grant global permissions to 'atlas' user so it can create the tables it needs:

hbase(main):001:0> grant 'atlas', 'RWXCA'

  • Start Atlas service in Ambari Admin Ui, Execute the following command in HBase shell, to revoke global permissions granted to 'atlas' user:

hbase(main):001:0> revoke 'atlas'

  • Execute the following commands in HBase shell, to enable Atlas to access necessary HBase tables

hbase(main):001:0> grant 'atlas', 'RWXCA', 'atlas_titan'

hbase(main):001:0> grant 'atlas', 'RWXCA', 'ATLAS_ENTITY_AUDIT_EVENTS'

hbase(main):001:0> exit

Return to the Ambari Admin UI , start the Altas service

You should be able to check by connecting back to Atlas dashboard , or simple watch the log

tail -f /var/log/atlas/application.log

For details please refer to the following : http://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.5.0/bk_data-governance/content/ch_hdp_data_gove...

View solution in original post